aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorWolfgang Breyha <wbreyha@gmx.net>2019-10-19 20:04:06 +0200
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2019-11-08 10:58:57 +0100
commitbbd66b26e4ef5c0b25d21027f7ed1c3bd3cdd7ed (patch)
treec077111f496dab17d35c757a06380c974adf9d95 /utils
parentf190dc89a49c40403fccef9cc43bc1eb6aed1626 (diff)
pps-tools: install timepps.h in location specified by RFC 2783
This is need by eg. gpsd to build with proper PPS support. It was already submitted once in #2892 which ended in a stalemate. Signed-off-by: Wolfgang Breyha <wbreyha@gmx.net>
Diffstat (limited to 'utils')
-rw-r--r--utils/pps-tools/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/utils/pps-tools/Makefile b/utils/pps-tools/Makefile
index 695114760..d5bfd897a 100644
--- a/utils/pps-tools/Makefile
+++ b/utils/pps-tools/Makefile
@@ -33,8 +33,8 @@ endef
TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
define Build/InstallDev
- $(INSTALL_DIR) $(1)/usr/include
- $(CP) $(PKG_BUILD_DIR)/timepps.h $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/include/sys
+ $(CP) $(PKG_BUILD_DIR)/timepps.h $(1)/usr/include/sys/
endef
define Package/pps-tools/install