aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2019-07-22 09:27:20 +0200
committerGitHub <noreply@github.com>2019-07-22 09:27:20 +0200
commitbb9711a5df55e357976daa4b7e79a9830562e020 (patch)
treec7d4a50a65ebe38dda834f405f07500ee49f104e /utils
parent615ff1f3e0fdd95e2ea6c76ce124016db78e8625 (diff)
parent8c77bcc19f4283813cdbb99842bb1c330fadf124 (diff)
Merge pull request #9332 from neheb/dom
domoticz: Fix compilation without deprecated OpenSSL APIs
Diffstat (limited to 'utils')
-rw-r--r--utils/domoticz/Makefile2
-rw-r--r--utils/domoticz/patches/020-openssl-deprecated.patch24
2 files changed, 25 insertions, 1 deletions
diff --git a/utils/domoticz/Makefile b/utils/domoticz/Makefile
index 7bd2ae06b..23a819768 100644
--- a/utils/domoticz/Makefile
+++ b/utils/domoticz/Makefile
@@ -12,7 +12,7 @@ PKG_VERSION_MAJOR:=4
PKG_VERSION_PATCH:=9700
PKG_COMMIT:=
PKG_VERSION:=$(PKG_VERSION_MAJOR).$(PKG_VERSION_PATCH)
-PKG_RELEASE:=3
+PKG_RELEASE:=4
ifeq ($(PKG_COMMIT),)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/utils/domoticz/patches/020-openssl-deprecated.patch b/utils/domoticz/patches/020-openssl-deprecated.patch
new file mode 100644
index 000000000..94ca26c26
--- /dev/null
+++ b/utils/domoticz/patches/020-openssl-deprecated.patch
@@ -0,0 +1,24 @@
+From 87749eb9b74d82dced807cc16fb011d4e3fb052d Mon Sep 17 00:00:00 2001
+From: Rosen Penev <rosenp@gmail.com>
+Date: Sat, 13 Jul 2019 17:28:06 -0700
+Subject: [PATCH] WebServerHelper: Fix compilation - deprecated APIs
+
+OpenSSL has initialization deprecated.
+---
+ main/WebServerHelper.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/main/WebServerHelper.cpp b/main/WebServerHelper.cpp
+index 98ebcf7b4..0a028595c 100644
+--- a/main/WebServerHelper.cpp
++++ b/main/WebServerHelper.cpp
+@@ -37,7 +37,9 @@ namespace http {
+ our_listener_port = web_settings.listening_port;
+ #ifdef WWW_ENABLE_SSL
+ if (secure_web_settings.is_enabled()) {
++#if (OPENSSL_VERSION_NUMBER < 0x10100000L) || defined(LIBRESSL_VERSION_NUMBER)
+ SSL_library_init();
++#endif
+ secureServer_.reset(new CWebServer());
+ bRet |= secureServer_->StartServer(secure_web_settings, serverpath, bIgnoreUsernamePassword);
+ serverCollection.push_back(secureServer_);