aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorPaul Fertser <fercerpav@gmail.com>2015-02-03 17:11:37 +0300
committerPaul Fertser <fercerpav@gmail.com>2015-02-03 17:11:37 +0300
commitad9ae24a29ce6265bfded62f8c3855cee693023e (patch)
tree16afca912eefbedb1c8cf062e7a78f4199d30680 /utils
parentd654a226fba50d7ccc8bd676f22c2cd357119e5d (diff)
openocd: fix package dependencies
OpenOCD autoselects libftdi1 when it's present, and should explicitly depend on it, same about libusb-0.1 API which is provided by libusb-compat. Signed-off-by: Paul Fertser <fercerpav@gmail.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/openocd/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/utils/openocd/Makefile b/utils/openocd/Makefile
index 929574b90..aadd3e2f3 100644
--- a/utils/openocd/Makefile
+++ b/utils/openocd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openocd
PKG_VERSION:=v0.8.0-258-gd537cfa
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://git.code.sf.net/p/openocd/code
@@ -32,7 +32,7 @@ define Package/openocd
CATEGORY:=Utilities
TITLE:=OpenOCD Utility
URL:=http://openocd.sf.net/
- DEPENDS:=+libusb-1.0 +libftdi +hidapi
+ DEPENDS:=+libusb-1.0 +libusb-compat +libftdi1 +hidapi
endef
define Package/openocd/description