aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-10-11 12:50:00 -0700
committerGitHub <noreply@github.com>2018-10-11 12:50:00 -0700
commita9f8712e63dbdb7aad08f286cd427d07cc46aec2 (patch)
treeb53204562b7084e74303c4b22cdec3137c3e09a0 /utils
parent0ecf61d51db948b230f3be88ea651dbd9819206d (diff)
cmdpad: Fix compile
Since the switch to GCC7, this has not compiled as it assumes gnu89 behavior. -fgnu89-inlining is not enough so use std=gnu89. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/cmdpad/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/utils/cmdpad/Makefile b/utils/cmdpad/Makefile
index 6c7356a40..a63e9e202 100644
--- a/utils/cmdpad/Makefile
+++ b/utils/cmdpad/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=cmdpad
PKG_VERSION:=0.0.3
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=@SF/cmdpad
@@ -28,6 +28,8 @@ define Package/cmdpad
URL:=http://cmdpad.sourceforge.net/index.php
endef
+TARGET_CFLAGS += -std=gnu89
+
CONFIGURE_ARGS += \
--enable-static \
--enable-shared