aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorFederico Capoano <f.capoano@openwisp.io>2024-03-19 10:52:31 -0300
committerTianling Shen <cnsztl@gmail.com>2024-05-04 19:07:15 +0800
commit9f54d987476f74f91ec545d1036cdbcdf455b2a1 (patch)
treed0d1edc57100f3b62c2367f4e1a5ac9477ed75f2 /utils
parent5181ce4a483711791329a13e07d29f9321d85178 (diff)
flashrom: strip leading whitespace from PROGRAMMER_ARGS
Newer version of meson do not allow empty arguments. Signed-off-by: Federico Capoano <f.capoano@openwisp.io>
Diffstat (limited to 'utils')
-rw-r--r--utils/flashrom/Makefile2
-rw-r--r--utils/flashrom/flashrom.mk3
2 files changed, 2 insertions, 3 deletions
diff --git a/utils/flashrom/Makefile b/utils/flashrom/Makefile
index e75add75e..cced9a846 100644
--- a/utils/flashrom/Makefile
+++ b/utils/flashrom/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=flashrom
PKG_VERSION:=1.3.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://download.flashrom.org/releases
diff --git a/utils/flashrom/flashrom.mk b/utils/flashrom/flashrom.mk
index 5ee91a8f0..454e95443 100644
--- a/utils/flashrom/flashrom.mk
+++ b/utils/flashrom/flashrom.mk
@@ -96,9 +96,8 @@ else
$(eval $(call Programmer,satamv,$(FLASHROM_PCI)))
endif
-comma := ,
MESON_ARGS += \
-Ddefault_programmer_name=$(DEFAULT_PROGRAMMER_NAME) \
- -Dprogrammer=$(subst $() $(),$(comma),$(PROGRAMMER_ARGS)) \
+ -Dprogrammer=$(subst $(space),$(comma),$(strip $(PROGRAMMER_ARGS))) \
-Dwerror=false \
-Dtests=disabled