aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authoraTanW <villy@sft.ru>2015-08-21 18:13:19 +0300
committeraTanW <villy@sft.ru>2015-08-21 18:13:19 +0300
commit9cad7e86a15143f976e95cb86b751ce8f47edd34 (patch)
tree501db02455e4648d779c3fb4007a4023b59fbb02 /utils
parent28804d8d9792d8e10c6008d8ea84c1cb3ce9d3e3 (diff)
gammu: bump to mainstream v 1.36.4, full-language version build fix
Signed-Off-By: Vitaly Protsko <villy@sft.ru> --- Makefile | 14 +++++++++++--- 1 file changed, 11 insertions(+), 3 deletions(-)
Diffstat (limited to 'utils')
-rw-r--r--utils/gammu/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/utils/gammu/Makefile b/utils/gammu/Makefile
index 0b29b5389..a1fd0b39d 100644
--- a/utils/gammu/Makefile
+++ b/utils/gammu/Makefile
@@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gammu
-PKG_VERSION:=1.36.3
+PKG_VERSION:=1.36.4
PKG_RELEASE:=1
PKG_SOURCE_URL:=http://dl.cihar.com/gammu/releases/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_MD5SUM:=d5a6914996ebedcd6cac6622f2e4018b
+PKG_MD5SUM:=5149da5ddf5a68e1e8a4a5c2e0131a45
PKG_MAINTAINER:=Vitaly Protsko <villy@sft.ru>
PKG_LICENCE:=GPL-2.0
@@ -36,7 +36,15 @@ define Package/gammu
endef
CMAKE_OPTIONS += -DWITH_LibDBI:BOOL=OFF
-
+ifneq ($(INTL_FULL),)
+CMAKE_OPTIONS += -DLIBINTL_INCLUDE_DIRS:PATH=$(INTL_PREFIX)/include
+CMAKE_OPTIONS += -DLIBINTL_LIBRARIES:STRING=intl
+endif
+ifneq ($(ICONV_FULL),)
+CMAKE_OPTIONS += -DDISABLE_ICONV=OFF
+CMAKE_OPTIONS += -DICONV_INCLUDE_DIRS:PATH=$(ICONV_PREFIX)/include
+CMAKE_OPTIONS += -DICONV_LIBRARIES:STRING=iconv
+endif
define Build/InstallDev
mkdir -p $(1)/usr/include