aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorkrant <aleksey.vasilenko@gmail.com>2024-04-12 07:26:06 +0300
committerRosen Penev <rosenp@gmail.com>2024-04-13 14:05:04 -0700
commit98aa6b8fde6a01c0a1338e7bfdf66b9fc3365a2e (patch)
tree3a8851ea3c8f0afb541435b0e2b8025fe78c6d41 /utils
parent2c94c9133d2b75900c90195eed2435763811d1a8 (diff)
fontconfig: update to 2.15.0
- Use up-to-date project URLs - Remove obsoleted patch Signed-off-by: krant <aleksey.vasilenko@gmail.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/fontconfig/Makefile10
-rw-r--r--utils/fontconfig/patches/001-revert-upstream-meson-commit.patch26
2 files changed, 5 insertions, 31 deletions
diff --git a/utils/fontconfig/Makefile b/utils/fontconfig/Makefile
index 54d8f0e02..ca21c419d 100644
--- a/utils/fontconfig/Makefile
+++ b/utils/fontconfig/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=fontconfig
-PKG_VERSION:=2.13.94
-PKG_RELEASE:=3
+PKG_VERSION:=2.15.0
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=https://fontconfig.org/release/
-PKG_HASH:=a5f052cb73fd479ffb7b697980510903b563bbb55b8f7a2b001fcfb94026003c
+PKG_SOURCE_URL:=https://www.freedesktop.org/software/fontconfig/release/
+PKG_HASH:=63a0658d0e06e0fa886106452b58ef04f21f58202ea02a94c39de0d3335d7c0e
PKG_MAINTAINER:=
PKG_LICENSE:=
@@ -31,7 +31,7 @@ define Package/fontconfig
SUBMENU:=Font-Utils
TITLE:=fontconfig
DEPENDS:=+libpthread +libexpat +libfreetype
- URL:=http://fontconfig.org/
+ URL:=https://www.freedesktop.org/wiki/Software/fontconfig/
endef
MESON_ARGS += \
diff --git a/utils/fontconfig/patches/001-revert-upstream-meson-commit.patch b/utils/fontconfig/patches/001-revert-upstream-meson-commit.patch
deleted file mode 100644
index bcd7ce8c8..000000000
--- a/utils/fontconfig/patches/001-revert-upstream-meson-commit.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Revert partially the upstream commit ae9ac2a1
-
- Subject: [PATCH] meson: fix cross-compilation issues with gperf header file preprocessing
-
- Pass c_args to the compiler when preprocessing the gperf header file,
- they might contain important bits without which compilation/preprocessing
- might fail (e.g. with clang on Android). cc.cmd_array() does not include
- the c_args and we can't easily look them up from the meson.build file, so
- we have to retrieve from the introspection info.
-
- This is basically the Meson equivalent to commit 57103773.
-
-Revert the host_cargs related part of the patch
-
-
---- a/src/cutout.py
-+++ b/src/cutout.py
-@@ -24,7 +24,7 @@ if __name__== '__main__':
- break
-
- cpp = args[1]
-- ret = subprocess.run(cpp + host_cargs + [args[0].input], stdout=subprocess.PIPE, check=True)
-+ ret = subprocess.run(cpp + [args[0].input], stdout=subprocess.PIPE, check=True)
-
- stdout = ret.stdout.decode('utf8')
-