aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2017-01-17 12:21:42 -0500
committerGitHub <noreply@github.com>2017-01-17 12:21:42 -0500
commit94a8fef2223e4b958a8fbbf46b47f3f4eae7aba7 (patch)
treec82f225fb925dc583a99da9c9bb549c7a36aa7e4 /utils
parenta52eee16d8fc779f29fef859a15fc11686224450 (diff)
parent99605fb63069befb79db8b0cc62f9520734b8263 (diff)
Merge pull request #3833 from riptidewave93/patch-1
util/beep: Add beep package
Diffstat (limited to 'utils')
-rw-r--r--utils/beep/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/utils/beep/Makefile b/utils/beep/Makefile
new file mode 100644
index 000000000..f78af91c2
--- /dev/null
+++ b/utils/beep/Makefile
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2017 Chris Blake (chrisrblake93@gmail.com)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=beep
+PKG_REV:=0d790fa45777896749a885c3b93b2c1476d59f20
+PKG_VERSION:=1.3
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=https://github.com/johnath/beep.git
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=$(PKG_REV)
+
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=COPYING
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/beep
+ SECTION:=sound
+ CATEGORY:=Sound
+ DEPENDS:=@(TARGET_x86||TARGET_x86_64) +kmod-pcspkr
+ TITLE:=Play beep sounds through a PC speaker
+ URL:=http://johnath.com/beep/README
+endef
+
+define Package/beep/description
+ This program plays beeps through the PC speaker
+endef
+
+MAKE_FLAGS += \
+ CFLAGS="$(TARGET_CFLAGS)"
+
+define Package/beep/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/beep $(1)/usr/bin
+endef
+
+$(eval $(call BuildPackage,beep))