aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2021-08-15 02:32:51 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2021-08-15 02:32:51 +0300
commit901a0b7b5e3c50d8eb0c9031c6b3b78c9a79abb0 (patch)
tree28860ff0bffc0d046b59bbe39da734b04a8b48e0 /utils
parent51f9a12a54dc2e7abcf9028490114d8bd926ac88 (diff)
rtl_433: disable SoapySDR
When building on a host with SoapySDR installed, the package fails to build as CMake picks up the host SoapySDR CMake module. As SoapySDR is not available in OpenWrt, simply disable SoapySDR to fix build. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'utils')
-rw-r--r--utils/rtl_433/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/utils/rtl_433/Makefile b/utils/rtl_433/Makefile
index cf3e44249..e9422af45 100644
--- a/utils/rtl_433/Makefile
+++ b/utils/rtl_433/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=rtl_433
PKG_VERSION:=20.11
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/merbanan/rtl_433/tar.gz/$(PKG_VERSION)?
@@ -33,6 +33,8 @@ define Package/rtl-sdr/description
rtl_433 turns your Realtek RTL2832 based DVB dongle into a 433.92MHz generic data receiver.
endef
+CMAKE_OPTIONS += -DENABLE_SOAPYSDR=NO
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/rtl_433.h $(1)/usr/include