aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-03-15 11:53:30 -0700
committerGitHub <noreply@github.com>2020-03-15 11:53:30 -0700
commit8fd12aa10ba6c92513aa2c34637addcd7932c770 (patch)
tree55f8b3b0a26eb6e336dde7e0a379fa731b55fc75 /utils
parente6d72a5b177442aa1052ad11dc91c64ea2299c1b (diff)
parent047fd15b54f3f9d6fc73a08b2de490a13c9054e9 (diff)
Merge pull request #11154 from dengqf6/antfs
[RFT] antfs: new package
Diffstat (limited to 'utils')
-rw-r--r--utils/antfs-mount/Makefile28
-rw-r--r--utils/antfs-mount/files/mount.ntfs2
2 files changed, 30 insertions, 0 deletions
diff --git a/utils/antfs-mount/Makefile b/utils/antfs-mount/Makefile
new file mode 100644
index 000000000..48ffc6f1c
--- /dev/null
+++ b/utils/antfs-mount/Makefile
@@ -0,0 +1,28 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=antfs-mount
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/antfs-mount
+ SECTION:=utils
+ CATEGORY:=Utilities
+ SUBMENU:=Filesystem
+ TITLE:=NTFS mount script for AVM NTFS driver
+ PKGARCH:=all
+ DEPENDS:=+kmod-fs-antfs
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Package/antfs-mount/install
+ $(INSTALL_DIR) $(1)/sbin
+ $(INSTALL_BIN) ./files/mount.ntfs $(1)/sbin
+endef
+
+$(eval $(call BuildPackage,antfs-mount))
diff --git a/utils/antfs-mount/files/mount.ntfs b/utils/antfs-mount/files/mount.ntfs
new file mode 100644
index 000000000..e97709aec
--- /dev/null
+++ b/utils/antfs-mount/files/mount.ntfs
@@ -0,0 +1,2 @@
+#!/bin/sh
+mount -t antfs "$@"