aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorDaniel Dickinson <lede@daniel.thecshore.com>2016-05-16 04:27:26 -0400
committerDaniel Dickinson <lede@daniel.thecshore.com>2016-06-19 17:34:43 -0400
commit8d4f5d8bda3324eacd7a2495cab3fc19905e9894 (patch)
tree50c958483223db5a179b54501631d2551ceffd02 /utils
parent99467692069037e576f151f24f83bc6115c010e4 (diff)
utils/tar: Default to acl and xattr support if it's core default
If we've enable POSIX ACL's and XATTR support as the default, then make tar build with such support by default as well. Signed-off-by: Daniel Dickinson <lede@daniel.thecshore.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/tar/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/utils/tar/Makefile b/utils/tar/Makefile
index d317329dc..96a64215b 100644
--- a/utils/tar/Makefile
+++ b/utils/tar/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=tar
PKG_VERSION:=1.29
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
@@ -39,10 +39,12 @@ define Package/tar/config
if PACKAGE_tar
config PACKAGE_TAR_POSIX_ACL
bool "tar: Enable POSIX ACL support"
+ default y if USE_FS_ACL_ATTR
default n
config PACKAGE_TAR_XATTR
bool "tar: Enable extended attribute (xattr) support"
+ default y if USE_FS_ACL_ATTR
default n
config PACKAGE_TAR_GZIP