aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2022-09-14 21:21:50 -0300
committerRosen Penev <rosenp@gmail.com>2022-09-22 01:22:28 -0700
commit8cb0ed95dd101b1c8d4b44482ef2033a202b030f (patch)
tree7247e3bb2ebb374c223d57ce8a438342a8f1be4a /utils
parent44443e12416c247661ad7886d6bf9af084d69e81 (diff)
opendoas: avoid libpam dependency
Package is failing to build because it picks up libpam dependency regardless of `BUSYBOX_CONFIG_PAM`. Use configure args --with-pam, --without-pam to assert the option. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/opendoas/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/utils/opendoas/Makefile b/utils/opendoas/Makefile
index 78f962f3b..23882d521 100644
--- a/utils/opendoas/Makefile
+++ b/utils/opendoas/Makefile
@@ -33,6 +33,8 @@ define Package/opendoas/description
of sudo with a fraction of the codebase.
endef
+CONFIGURE_ARGS += $(if $(CONFIG_BUSYBOX_CONFIG_PAM),--with,--without)-pam
+
define Package/opendoas/install
$(INSTALL_DIR) $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/doas $(1)/usr/bin/