aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2023-09-18 20:16:14 +0300
committerHannu Nyman <hannu.nyman@iki.fi>2023-09-18 22:13:41 +0300
commit87a9305ddd5a61602c5f283996352e1122afaf1e (patch)
tree679343fc64e834495188531e9a3d60b637910f79 /utils
parentaca50a5af779e3577520288181a56377c8855300 (diff)
collectd: remove target dependency from cpufreq plugin
We currently have more package architectures supporting CPU frequency scaling than earlier, and the package architecture vs. CPU target SDK matching does not fully reflect that. (E.g. aarch64_cortex-a53 is currently using bcm27xx/bcm2710) Simplify things by removing the target dependency and let the plugin be built for all architectures. Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Diffstat (limited to 'utils')
1 files changed, 2 insertions, 2 deletions
diff --git a/utils/collectd/Makefile b/utils/collectd/Makefile
index 875307c17..0119c88aa 100644
--- a/utils/collectd/Makefile
+++ b/utils/collectd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=collectd
PKG_VERSION:=5.12.0
-PKG_RELEASE:=48
+PKG_RELEASE:=49
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://collectd.org/files/ \
@@ -463,7 +463,7 @@ $(eval $(call BuildPlugin,chrony,chrony status input,chrony,))
$(eval $(call BuildPlugin,conntrack,connection tracking table size input,conntrack,))
$(eval $(call BuildPlugin,contextswitch,context switch input,contextswitch,))
$(eval $(call BuildPlugin,cpu,CPU input,cpu,))
-$(eval $(call BuildPlugin,cpufreq,CPU Freq input,cpufreq,@(TARGET_x86||TARGET_x86_64||TARGET_mvebu||TARGET_ipq806x||TARGET_armsr||TARGET_ipq40xx||TARGET_bcm27xx_bcm2709||TARGET_rockchip||TARGET_mediatek||TARGET_qualcommax))) # Only enable on targets with CPUs supporting frequency scaling
+$(eval $(call BuildPlugin,cpufreq,CPU Freq input,cpufreq,))
$(eval $(call BuildPlugin,csv,CSV output,csv,))
$(eval $(call BuildPlugin,curl,cURL input,curl,+PACKAGE_collectd-mod-curl:libcurl))
#$(eval $(call BuildPlugin,dbi,relational database input,dbi,+PACKAGE_collectd-mod-dbi:libdbi))