aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2015-08-25 16:10:52 -0400
committerTed Hess <thess@kitschensync.net>2015-08-25 19:04:07 -0400
commit85597bc84d75028aaa105713536a93dd94005f26 (patch)
tree088f14eb3e393d9182e92b41c53b32e1f3e4d3a7 /utils
parent6ce677caf0fb6fc4dbde8b0a283bb214f84e1423 (diff)
crelay: Fix link error with BUILD_NLS=y
Signed-off-by: Ted Hess <thess@kitschensync.net>
Diffstat (limited to 'utils')
-rw-r--r--utils/crelay/Makefile2
-rw-r--r--utils/crelay/patches/020-link_using_LDFLAGS.patch11
2 files changed, 13 insertions, 0 deletions
diff --git a/utils/crelay/Makefile b/utils/crelay/Makefile
index 8a5f7dc90..04fa0ae26 100644
--- a/utils/crelay/Makefile
+++ b/utils/crelay/Makefile
@@ -22,6 +22,7 @@ PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:=LICENSE
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
define Package/crelay
SECTION:=utils
@@ -52,6 +53,7 @@ TARGET_CFLAGS+= \
-I$(STAGING_DIR)/usr/include/libftdi1 \
-I$(STAGING_DIR)/usr/include/hidapi
+TARGET_LDFLAGS+= $(if $(ICONV_FULL),-liconv)
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR)/src \
diff --git a/utils/crelay/patches/020-link_using_LDFLAGS.patch b/utils/crelay/patches/020-link_using_LDFLAGS.patch
new file mode 100644
index 000000000..9154b08cb
--- /dev/null
+++ b/utils/crelay/patches/020-link_using_LDFLAGS.patch
@@ -0,0 +1,11 @@
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -61,7 +61,7 @@ all: $(BIN)
+
+ $(BIN): $(OBJ)
+ @echo "[Link $(BIN)] with libs $(LIBS)"
+- @$(CC) -o $(BIN) $(OBJ) $(LIBS)
++ @$(CC) -o $(BIN) $(OBJ) $(LDFLAGS) $(LIBS)
+
+ .c.o:
+ @echo "[Compile $<]"