aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-08-08 09:46:56 -0700
committerGitHub <noreply@github.com>2019-08-08 09:46:56 -0700
commit812f86a7296034434ab0d5bb8c2a55fbdff84060 (patch)
treef1b216ab260c1e95afd0ca8c68595fac82d1d44f /utils
parent304ca4b5ba6d2602c924c0dad43c16f68b4da3b0 (diff)
parent90d81afaed5757587234f8edf2f501a8afccae3c (diff)
Merge pull request #9588 from RussellSenior/update-gpsd
gpsd: update to v3.19
Diffstat (limited to 'utils')
-rw-r--r--utils/gpsd/Makefile8
-rw-r--r--utils/gpsd/patches/010-musl.patch40
2 files changed, 4 insertions, 44 deletions
diff --git a/utils/gpsd/Makefile b/utils/gpsd/Makefile
index dd9d9a9d5..55c975d0a 100644
--- a/utils/gpsd/Makefile
+++ b/utils/gpsd/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gpsd
-PKG_VERSION:=3.17
-PKG_RELEASE:=3
+PKG_VERSION:=3.19
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SAVANNAH/$(PKG_NAME)
-PKG_HASH:=68e0dbecfb5831997f8b3d6ba48aed812eb465d8c0089420ab68f9ce4d85e77a
+PKG_HASH:=27dd24d45b2ac69baab7933da2bf6ae5fb0be90130f67e753c110a3477155f39
PKG_MAINTAINER:=Pushpal Sidhu <psidhu.devel@gmail.com>
PKG_LICENSE:=BSD-3-Clause
@@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/scons.mk
define Package/gpsd/Default
DEPENDS+= +libusb-1.0
- URL:=http://catb.org/gpsd/
+ URL:=https://gpsd.gitlab.io/gpsd/
endef
define Package/gpsd/Default/description
diff --git a/utils/gpsd/patches/010-musl.patch b/utils/gpsd/patches/010-musl.patch
deleted file mode 100644
index a2ba95112..000000000
--- a/utils/gpsd/patches/010-musl.patch
+++ /dev/null
@@ -1,40 +0,0 @@
---- a/driver_ais.c
-+++ b/driver_ais.c
-@@ -24,6 +24,7 @@
-
- /* strlcpy() needs _DARWIN_C_SOURCE */
- #define _DARWIN_C_SOURCE
-+#define _BSD_SOURCE
-
- #include <stdlib.h>
- #include <string.h>
---- a/gpsctl.c
-+++ b/gpsctl.c
-@@ -15,6 +15,7 @@
-
- /* strlcpy() needs _DARWIN_C_SOURCE */
- #define _DARWIN_C_SOURCE
-+#define _BSD_SOURCE
-
- #include <stdio.h>
- #include <stdlib.h>
---- a/gpsd_json.c
-+++ b/gpsd_json.c
-@@ -24,6 +24,7 @@ PERMISSIONS
- #define __DARWIN_C_LEVEL 200112L
- /* strlcpy() needs _DARWIN_C_SOURCE */
- #define _DARWIN_C_SOURCE
-+#define _BSD_SOURCE
-
- #include <stdio.h>
- #include <math.h>
---- a/libgpsd_core.c
-+++ b/libgpsd_core.c
-@@ -20,6 +20,7 @@
-
- /* strlcpy() needs _DARWIN_C_SOURCE */
- #define _DARWIN_C_SOURCE
-+#define _BSD_SOURCE
-
- #include <time.h>
- #include <stdio.h>