aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2016-03-24 07:42:20 +0100
committerStijn Tintel <stijn@linux-ipv6.be>2016-03-27 04:34:49 +0200
commit7ea7af512549d508c1886397c80fca398604e5f9 (patch)
tree8ee422199fc8bdad48cf189fef777fed8284d69a /utils
parent0e105b356e6af33b0cddfb77a156e103a2b596d4 (diff)
pciutils: remove eudev dependency
Disable udev hwdb support instead of depending on eudev. This restores the old behavior of pciutils. It never depended on udev. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'utils')
-rw-r--r--utils/pciutils/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/utils/pciutils/Makefile b/utils/pciutils/Makefile
index 28c47668e..209a3ed09 100644
--- a/utils/pciutils/Makefile
+++ b/utils/pciutils/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=pciutils
PKG_VERSION:=3.4.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@KERNEL/software/utils/pciutils
@@ -29,7 +29,7 @@ define Package/pciutils
CATEGORY:=Utilities
TITLE:=Linux PCI Utilities
URL:=http://mj.ucw.cz/pciutils.shtml
- DEPENDS:=+eudev +libkmod +zlib
+ DEPENDS:=+libkmod +zlib
endef
define Package/pciutils/description
@@ -48,6 +48,7 @@ MAKE_FLAGS += \
CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
PREFIX="/usr" \
HOST="$(GNU_TARGET_NAME)" \
+ HWDB="no" \
ZLIB="yes"
ifneq ($(CONFIG_USE_GLIBC),)