aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-06-05 15:11:47 +0200
committerJo-Philipp Wich <jo@mein.io>2016-06-05 15:11:47 +0200
commit7d92f98ca7f73ae3b8cac69dd9721415e765e844 (patch)
tree4a503e30d94a1c3d2718d96f4fa0214e396f42a9 /utils
parent601d06dca4220d2678bf4e3ed52336d494eda3f0 (diff)
parent6912f6ff082564b62b20385626b2e6c137973d99 (diff)
Merge pull request #2626 from bk138/gzip
Import gzip from oldpackages
Diffstat (limited to 'utils')
-rw-r--r--utils/gzip/Makefile63
1 files changed, 63 insertions, 0 deletions
diff --git a/utils/gzip/Makefile b/utils/gzip/Makefile
new file mode 100644
index 000000000..d1236f212
--- /dev/null
+++ b/utils/gzip/Makefile
@@ -0,0 +1,63 @@
+#
+# Copyright (C) 2006-2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gzip
+PKG_VERSION:=1.7
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/gzip
+PKG_MD5SUM:=c4abae2ddd5c6f39c6f8169693cc7ac0
+PKG_LICENSE:=GPL-3.0+
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/gzip
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=gzip (GNU zip) is a compression utility.
+ URL:=https://www.gnu.org/software/gzip/
+ MAINTAINER:=Christian Beier <dontmind@freeshell.org>
+endef
+
+define Package/gzip/description
+ gzip (GNU zip) is a compression utility designed to be a \
+ replacement for compress.
+endef
+
+CONFIGURE_VARS += \
+ gl_cv_func_getopt_gnu=yes \
+ ac_cv_search_clock_gettime=no
+
+define Package/gzip/install
+ $(SED) 's,/bin/bash,/bin/sh,g' $(PKG_INSTALL_DIR)/usr/bin/{gunzip,zcat}
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/{gunzip,gzip,zcat} $(1)/usr/bin/
+endef
+
+define Package/gzip/postinst
+#!/bin/sh
+for app in gunzip gzip zcat; do
+ ln -sf ../usr/bin/$$app $${IPKG_INSTROOT}/bin/$$app
+done
+endef
+
+define Package/gzip/postrm
+#!/bin/sh
+for app in gunzip gzip zcat; do
+ ln -sf busybox $${IPKG_INSTROOT}/bin/$$app
+ $${IPKG_INSTROOT}/bin/$$app 2>&1 | grep 'applet not found' > /dev/null 2>&1 && rm $${IPKG_INSTROOT}/bin/$$app
+done
+exit 0
+endef
+
+$(eval $(call BuildPackage,gzip))
+