aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2014-08-12 08:49:34 +0200
committerSteven Barth <steven@midlink.org>2014-08-12 08:49:34 +0200
commit7cf7c8675a87097bb8086eb446177fcba8214600 (patch)
treef5ee56c61570ee73038acf1ce544c0a89e4de09f /utils
parent272f3b43cdd63e00fda8ca400596a26c5c82ac4e (diff)
shadow: update to 4.2.1, add PKG_LICENSE
Signed-off-by: Steven Barth <steven@midlink.org>
Diffstat (limited to 'utils')
-rw-r--r--utils/shadow/Makefile12
-rw-r--r--utils/shadow/patches/001-busybox_ash.patch4
-rw-r--r--utils/shadow/patches/002-disable-ruser-lookup.patch10
-rw-r--r--utils/shadow/patches/003-fix-disabling-subids.patch32
4 files changed, 45 insertions, 13 deletions
diff --git a/utils/shadow/Makefile b/utils/shadow/Makefile
index dc665bf78..8e91f9b36 100644
--- a/utils/shadow/Makefile
+++ b/utils/shadow/Makefile
@@ -8,13 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=shadow
-PKG_VERSION:=4.1.5.1
-PKG_RELEASE:=4
+PKG_VERSION:=4.2.1
+PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://pkg-shadow.alioth.debian.org/releases
-PKG_MD5SUM:=a00449aa439c69287b6d472191dc2247
+PKG_MD5SUM:=2bfafe7d4962682d31b5eba65dba4fc8
PKG_MAINTAINER:=Steven Barth <cyrus@openwrt.org>
+PKG_LICENSE:=BSD-3-Clause
PKG_FIXUP:=autoreconf
PKG_BUILD_PARALLEL:=1
@@ -35,7 +36,8 @@ CONFIGURE_ARGS += \
--without-acl \
--without-attr \
--without-tcb \
- --without-nscd
+ --without-nscd \
+ --disable-subordinate-ids \
define Package/shadow/Default
SECTION:=utils
diff --git a/utils/shadow/patches/001-busybox_ash.patch b/utils/shadow/patches/001-busybox_ash.patch
index f21eee1bf..a16dad26a 100644
--- a/utils/shadow/patches/001-busybox_ash.patch
+++ b/utils/shadow/patches/001-busybox_ash.patch
@@ -1,9 +1,7 @@
-diff --git a/etc/login.defs b/etc/login.defs
-index 5b6fab3..79eeccf 100644
--- a/etc/login.defs
+++ b/etc/login.defs
@@ -111,7 +111,7 @@ NOLOGINS_FILE /etc/nologin
- # command is "-su". If not defined, then "ps" would display the
+ # command as "-su". If not defined, then ps(1) will display the
# name of the shell actually being run, e.g. something like "-sh".
#
-SU_NAME su
diff --git a/utils/shadow/patches/002-disable-ruser-lookup.patch b/utils/shadow/patches/002-disable-ruser-lookup.patch
index 7a6f38e79..a7ef1f74d 100644
--- a/utils/shadow/patches/002-disable-ruser-lookup.patch
+++ b/utils/shadow/patches/002-disable-ruser-lookup.patch
@@ -1,10 +1,10 @@
--- a/configure.in
+++ b/configure.in
-@@ -195,7 +195,6 @@ AC_DEFINE_UNQUOTED(PASSWD_PROGRAM, "$sha
- dnl XXX - quick hack, should disappear before anyone notices :).
+@@ -197,7 +197,6 @@ dnl XXX - quick hack, should disappear b
AC_DEFINE(USE_SYSLOG, 1, [Define to use syslog().])
- AC_DEFINE(RLOGIN, 1, [Define if login should support the -r flag for rlogind.])
--AC_DEFINE(RUSEROK, 0, [Define to the ruserok() "success" return value (0 or 1).])
+ if test "$ac_cv_func_ruserok" = "yes"; then
+ AC_DEFINE(RLOGIN, 1, [Define if login should support the -r flag for rlogind.])
+- AC_DEFINE(RUSEROK, 0, [Define to the ruserok() "success" return value (0 or 1).])
+ fi
AC_ARG_ENABLE(shadowgrp,
- [AC_HELP_STRING([--enable-shadowgrp], [enable shadow group support @<:@default=yes@:>@])],
diff --git a/utils/shadow/patches/003-fix-disabling-subids.patch b/utils/shadow/patches/003-fix-disabling-subids.patch
new file mode 100644
index 000000000..bbc65c7d1
--- /dev/null
+++ b/utils/shadow/patches/003-fix-disabling-subids.patch
@@ -0,0 +1,32 @@
+--- a/src/usermod.c
++++ b/src/usermod.c
+@@ -1361,6 +1361,7 @@ static void process_flags (int argc, cha
+ exit (E_UID_IN_USE);
+ }
+
++#ifdef ENABLE_SUBIDS
+ if ( (vflg || Vflg)
+ && !is_sub_uid) {
+ fprintf (stderr,
+@@ -1376,6 +1377,7 @@ static void process_flags (int argc, cha
+ Prog, sub_gid_dbname (), "-w", "-W");
+ exit (E_USAGE);
+ }
++#endif
+ }
+
+ /*
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -52,7 +52,10 @@ usbin_PROGRAMS = \
+ noinst_PROGRAMS = id sulogin
+
+ suidbins = su
+-suidubins = chage chfn chsh expiry gpasswd newgrp passwd newuidmap newgidmap
++suidubins = chage chfn chsh expiry gpasswd newgrp passwd
++if ENABLE_SUBIDS
++ suidubins += newuidmap newgidmap
++endif
+ if ACCT_TOOLS_SETUID
+ suidubins += chage chgpasswd chpasswd groupadd groupdel groupmod newusers useradd userdel usermod
+ endif