aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-09-18 14:50:34 -0700
committerGitHub <noreply@github.com>2021-09-18 14:50:34 -0700
commit7049dd0ec5fd36e10f1e2693570edb8f698b2eb5 (patch)
tree52ad668b0afc6714ed3a7c37b681cd585fc6f77d /utils
parent563f84d4694aaa978f9ee72c593ef67ed55b423a (diff)
parent61996a000ed98867187a657320cc2fa913e4eb77 (diff)
Merge pull request #16364 from stintel/mtools
mtools: fix host lib leakage + version bump
Diffstat (limited to 'utils')
-rw-r--r--utils/mtools/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/utils/mtools/Makefile b/utils/mtools/Makefile
index 66400e5b5..55a404dcc 100644
--- a/utils/mtools/Makefile
+++ b/utils/mtools/Makefile
@@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mtools
-PKG_VERSION:=4.0.26
+PKG_VERSION:=4.0.35
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@GNU/mtools
-PKG_HASH:=539f1c8b476a16e198d8bcb10a5799e22e69de49d854f7dbd85b64c2a45dea1a
+PKG_HASH:=34769e173751d2f0d891a08c76c80427e929b8ee43438019b8666cc3d7a44749
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
@@ -30,6 +30,8 @@ define Package/mtools/description
Mtools is a collection of utilities to access MS-DOS disks from GNU and Unix without mounting them.
endef
+CONFIGURE_VARS += ac_cv_have_x="have_x=no"
+
define Package/mtools/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/amuFormat.sh $(1)/usr/bin/