aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2022-10-28 13:17:13 +0200
committerPaul Spooren <mail@aparcar.org>2022-10-29 10:00:27 +0200
commit646fbeafdc6ad4b39217f767216c8fac27776151 (patch)
tree5ca754a5dcf36d2994951023d22a23114f06b6e3 /utils
parentde85ed88a70968acfd9bf47a2ea5d86d14fc0ae0 (diff)
attendedsysupgrade-common: update ASU CA pubkey
The old key was overwritten during a machine migration and the current worker key is no longer valid. To create new valid worker certificates this commit adds a new CA pubkey. To update running OpenWrt devices via a client one needs to force install it or upgrade to the latest version of `attendedsysupgrade-common` - I'm sorry for the inconvenience. This change is only related to the `usign` pubkey and `ucert` certificate which is used to sign all created images on the server. While at it, use INSTALL_DATA instead of INSTALL_BIN. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'utils')
-rw-r--r--utils/attendedsysupgrade-common/Makefile4
-rw-r--r--utils/attendedsysupgrade-common/files/86241a707a30cb7f2
-rw-r--r--utils/attendedsysupgrade-common/files/8a11255d14aef6c82
3 files changed, 4 insertions, 4 deletions
diff --git a/utils/attendedsysupgrade-common/Makefile b/utils/attendedsysupgrade-common/Makefile
index 4408b81d4..766e8b0b9 100644
--- a/utils/attendedsysupgrade-common/Makefile
+++ b/utils/attendedsysupgrade-common/Makefile
@@ -49,10 +49,10 @@ endef
define Package/attendedsysupgrade-common/install
$(INSTALL_DIR) $(1)/etc/uci-defaults/
- $(INSTALL_BIN) ./files/attendedsysupgrade.defaults $(1)/etc/uci-defaults/attendedsysupgrade
+ $(INSTALL_DATA) ./files/attendedsysupgrade.defaults $(1)/etc/uci-defaults/attendedsysupgrade
$(INSTALL_DIR) $(1)/etc/opkg/keys/
- $(INSTALL_BIN) ./files/86241a707a30cb7f $(1)/etc/opkg/keys/86241a707a30cb7f
+ $(INSTALL_DATA) ./files/8a11255d14aef6c8 $(1)/etc/opkg/keys/8a11255d14aef6c8
endef
$(eval $(call BuildPackage,attendedsysupgrade-common))
diff --git a/utils/attendedsysupgrade-common/files/86241a707a30cb7f b/utils/attendedsysupgrade-common/files/86241a707a30cb7f
deleted file mode 100644
index 800732714..000000000
--- a/utils/attendedsysupgrade-common/files/86241a707a30cb7f
+++ /dev/null
@@ -1,2 +0,0 @@
-untrusted comment: ASU CA pubkey
-RWSGJBpwejDLf4OApA5SOavh0GBlBFY9FhqxnivUQHpi0/t0QRI98LPW
diff --git a/utils/attendedsysupgrade-common/files/8a11255d14aef6c8 b/utils/attendedsysupgrade-common/files/8a11255d14aef6c8
new file mode 100644
index 000000000..ef206003b
--- /dev/null
+++ b/utils/attendedsysupgrade-common/files/8a11255d14aef6c8
@@ -0,0 +1,2 @@
+untrusted comment: ASU CA pubkey 2022
+RWSKESVdFK72yB0Y5q0ckpqqXU+51UbFYYMPRrOTMdNjvLkU1tjJTSiU