aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-06-05 13:25:45 -0700
committerFlorian Fainelli <f.fainelli@gmail.com>2017-06-05 17:18:51 -0700
commit5374d8635dc00afa68e6d3467263129f75ce3ffb (patch)
treec4a2e310c9e240cf987a4381e179babf3880de3d /utils
parentfdd3f3f7f955266333b1957be93d3cd58a88ef85 (diff)
squashfs-tools: Pass down TARGET_CFLAGS, CPPFLAGS and LDFLAGs
This fixes build errors with external toolchains that don't automatically search for headers in STAGING_DIR: mipsel-linux-gnu-gcc -I. -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE -DCOMP_DEFAULT=\"gzip\" -Wall -DGZIP_SUPPORT -c -o gzip_wrapper.o gzip_wrapper.c gzip_wrapper.c:27:18: fatal error: zlib.h: No such file or directory #include <zlib.h> ^ compilation terminated. make[3]: *** [gzip_wrapper.o] Error 1 Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/squashfs-tools/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/utils/squashfs-tools/Makefile b/utils/squashfs-tools/Makefile
index b904fa4e0..cbba3ed51 100644
--- a/utils/squashfs-tools/Makefile
+++ b/utils/squashfs-tools/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=squashfs-tools
PKG_VERSION:=4.3
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:=COPYING
@@ -69,6 +69,8 @@ endif
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR)/squashfs-tools \
CC="$(TARGET_CC)" \
+ EXTRA_CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
+ EXTRA_LDFLAGS="$(TARGET_LDFLAGS)" \
$(MAKE_FLAGS) \
mksquashfs unsquashfs
endef