aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorVladimir Ermakov <vooon341@gmail.com>2024-04-24 12:57:36 +0200
committerRosen Penev <rosenp@gmail.com>2024-04-30 13:45:48 -0700
commit48e103ef0db03821aa9e6724b71a69cfb4990fc3 (patch)
tree1950151e4eb7f259cc8bc4b87cc18292ce49fa03 /utils
parent55ddb6e1ff0aa853208e71e63cee3189c7b74a57 (diff)
qemu: update to 9.0.0
- update version: 9.0.0 - refresh patches Signed-off-by: Vladimir Ermakov <vooon341@gmail.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/qemu/Makefile4
-rw-r--r--utils/qemu/patches/0001-configure-allow-disable-fortify_source.patch2
-rw-r--r--utils/qemu/patches/0007-qga-invoke-separate-applets-for-guest-shutdown-modes.patch6
-rw-r--r--utils/qemu/patches/0010-no-tests.patch4
4 files changed, 8 insertions, 8 deletions
diff --git a/utils/qemu/Makefile b/utils/qemu/Makefile
index 29e4fd543..aa6aed30f 100644
--- a/utils/qemu/Makefile
+++ b/utils/qemu/Makefile
@@ -9,10 +9,10 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=qemu
-PKG_VERSION:=8.2.2
+PKG_VERSION:=9.0.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_HASH:=847346c1b82c1a54b2c38f6edbd85549edeb17430b7d4d3da12620e2962bc4f3
+PKG_HASH:=32708ac66c30d8c892633ea968c771c1c76d597d70ddead21a0d22ccf386da69
PKG_SOURCE_URL:=https://download.qemu.org/
PKG_LICENSE:=GPL-2.0-only
PKG_LICENSE_FILES:=LICENSE tcg/LICENSE
diff --git a/utils/qemu/patches/0001-configure-allow-disable-fortify_source.patch b/utils/qemu/patches/0001-configure-allow-disable-fortify_source.patch
index 1843df22a..ccd2fc6d0 100644
--- a/utils/qemu/patches/0001-configure-allow-disable-fortify_source.patch
+++ b/utils/qemu/patches/0001-configure-allow-disable-fortify_source.patch
@@ -11,7 +11,7 @@ OpenWrt base build system decide flavor of fortify_source to use
--- a/configure
+++ b/configure
-@@ -757,6 +757,8 @@ for opt do
+@@ -758,6 +758,8 @@ for opt do
;;
--gdb=*) gdb_bin="$optarg"
;;
diff --git a/utils/qemu/patches/0007-qga-invoke-separate-applets-for-guest-shutdown-modes.patch b/utils/qemu/patches/0007-qga-invoke-separate-applets-for-guest-shutdown-modes.patch
index 53c82f990..94061b8bf 100644
--- a/utils/qemu/patches/0007-qga-invoke-separate-applets-for-guest-shutdown-modes.patch
+++ b/utils/qemu/patches/0007-qga-invoke-separate-applets-for-guest-shutdown-modes.patch
@@ -13,7 +13,7 @@ https://gitlab.alpinelinux.org/alpine/aports/commit/76b81b486480fd9c3294cd420bcf
--- a/qga/commands-posix.c
+++ b/qga/commands-posix.c
-@@ -76,6 +76,7 @@ static void ga_wait_child(pid_t pid, int
+@@ -79,6 +79,7 @@ static void ga_wait_child(pid_t pid, int
void qmp_guest_shutdown(const char *mode, Error **errp)
{
const char *shutdown_flag;
@@ -21,7 +21,7 @@ https://gitlab.alpinelinux.org/alpine/aports/commit/76b81b486480fd9c3294cd420bcf
Error *local_err = NULL;
pid_t pid;
int status;
-@@ -97,10 +98,13 @@ void qmp_guest_shutdown(const char *mode
+@@ -100,10 +101,13 @@ void qmp_guest_shutdown(const char *mode
slog("guest-shutdown called, mode: %s", mode);
if (!mode || strcmp(mode, "powerdown") == 0) {
shutdown_flag = powerdown_flag;
@@ -35,7 +35,7 @@ https://gitlab.alpinelinux.org/alpine/aports/commit/76b81b486480fd9c3294cd420bcf
} else {
error_setg(errp,
"mode is invalid (valid values are: halt|powerdown|reboot");
-@@ -125,6 +129,7 @@ void qmp_guest_shutdown(const char *mode
+@@ -128,6 +132,7 @@ void qmp_guest_shutdown(const char *mode
execl("/sbin/shutdown", "shutdown", "-h", shutdown_flag, "+0",
"hypervisor initiated shutdown", (char *)NULL);
#endif
diff --git a/utils/qemu/patches/0010-no-tests.patch b/utils/qemu/patches/0010-no-tests.patch
index 460f0fab2..92f8c5ac8 100644
--- a/utils/qemu/patches/0010-no-tests.patch
+++ b/utils/qemu/patches/0010-no-tests.patch
@@ -1,6 +1,6 @@
--- a/meson.build
+++ b/meson.build
-@@ -3513,10 +3513,6 @@ subdir('common-user')
+@@ -3576,10 +3576,6 @@ subdir('common-user')
subdir('bsd-user')
subdir('linux-user')
@@ -11,7 +11,7 @@
# accel modules
tcg_real_module_ss = ss.source_set()
tcg_real_module_ss.add_all(when: 'CONFIG_TCG_MODULAR', if_true: tcg_module_ss)
-@@ -4012,10 +4008,6 @@ subdir('scripts')
+@@ -4094,10 +4090,6 @@ subdir('scripts')
subdir('tools')
subdir('pc-bios')
subdir('docs')