aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorYuhei OKAWA <tochiro.srchack@gmail.com>2019-11-05 23:46:43 +0900
committerYuhei OKAWA <tochiro.srchack@gmail.com>2019-11-06 18:45:12 +0900
commit478742118340db14de7cdf3fef8f53f66147886a (patch)
treeebdc75642f60ef7e5e6a022a0230fee3199612ac /utils
parentf095101399db297ce327dc3dd63e04a37c4a1ad5 (diff)
open-vm-tools: bump to version 11.0.1
tested x86 generic on ESXi 6.5u2 Signed-off-by: Yuhei OKAWA <tochiro.srchack@gmail.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/open-vm-tools/Makefile12
-rw-r--r--utils/open-vm-tools/patches/0001-configure.ac-don-t-use-dnet-config.patch8
-rw-r--r--utils/open-vm-tools/patches/0008-Rename-poll.h-to-vm_poll.h.patch39
3 files changed, 14 insertions, 45 deletions
diff --git a/utils/open-vm-tools/Makefile b/utils/open-vm-tools/Makefile
index c1af74ec9..1ec7d2d9b 100644
--- a/utils/open-vm-tools/Makefile
+++ b/utils/open-vm-tools/Makefile
@@ -8,17 +8,19 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=open-vm-tools
-PKG_VERSION:=10.3.10
+PKG_VERSION:=11.0.1
PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-12406962.tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-14773994.tar.gz
PKG_SOURCE_URL:=https://github.com/vmware/open-vm-tools/releases/download/stable-$(PKG_VERSION)
-PKG_HASH:=a3c02595c802680be258d6249513c76502d383a59597079b10984bb9136dbef5
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-12406962
+PKG_HASH:=8a707df98b6eb40195d7deaf09def5ef03c19c83ca418f8bf23c18405ebf2981
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-14773994
PKG_INSTALL:=1
+PKG_BUILD_DEPENDS:=glib2/host
+
PKG_FIXUP:=autoreconf
-PKG_LICENSE:=LGPL-2.1
+PKG_LICENSE:=LGPL-2.1-or-later
PKG_LICENSE_FILES:=LICENSE
include $(INCLUDE_DIR)/package.mk
diff --git a/utils/open-vm-tools/patches/0001-configure.ac-don-t-use-dnet-config.patch b/utils/open-vm-tools/patches/0001-configure.ac-don-t-use-dnet-config.patch
index 6f9636874..5f4c0e285 100644
--- a/utils/open-vm-tools/patches/0001-configure.ac-don-t-use-dnet-config.patch
+++ b/utils/open-vm-tools/patches/0001-configure.ac-don-t-use-dnet-config.patch
@@ -10,12 +10,4 @@ diff -urN a/configure.ac b/configure.ac
[],
[dnet.h],
[intf_open],
-@@ -959,7 +959,7 @@
-
- if test $have_dnet = "no"; then
- AC_MSG_ERROR(
-- [dnet-config was not found on your PATH. Please configure without dnet (using --without-dnet) or install dnet - http://libdnet.sourceforge.net])
-+ [dnet was not found. Please configure without dnet (using --without-dnet) or install dnet - http://libdnet.sourceforge.net])
- fi
- fi
diff --git a/utils/open-vm-tools/patches/0008-Rename-poll.h-to-vm_poll.h.patch b/utils/open-vm-tools/patches/0008-Rename-poll.h-to-vm_poll.h.patch
index ceef79450..5102189a5 100644
--- a/utils/open-vm-tools/patches/0008-Rename-poll.h-to-vm_poll.h.patch
+++ b/utils/open-vm-tools/patches/0008-Rename-poll.h-to-vm_poll.h.patch
@@ -1,5 +1,5 @@
diff --git a/lib/asyncsocket/asyncsocket.c b/lib/asyncsocket/asyncsocket.c
-index e0a68e7e..b9675674 100644
+index 07a5d04b..01181a95 100644
--- a/lib/asyncsocket/asyncsocket.c
+++ b/lib/asyncsocket/asyncsocket.c
@@ -86,7 +86,7 @@
@@ -12,7 +12,7 @@ index e0a68e7e..b9675674 100644
#include "err.h"
#include "hostinfo.h"
diff --git a/lib/hgfsServer/hgfsServer.c b/lib/hgfsServer/hgfsServer.c
-index 991a7941..ed0c09f9 100644
+index 46224551..fc691286 100644
--- a/lib/hgfsServer/hgfsServer.c
+++ b/lib/hgfsServer/hgfsServer.c
@@ -48,7 +48,7 @@
@@ -25,7 +25,7 @@ index 991a7941..ed0c09f9 100644
#include "vm_basic_asm.h"
#include "unicodeOperations.h"
diff --git a/lib/include/asyncsocket.h b/lib/include/asyncsocket.h
-index 524147ea..103f944f 100644
+index 95a5e464..a4b4e5aa 100644
--- a/lib/include/asyncsocket.h
+++ b/lib/include/asyncsocket.h
@@ -164,7 +164,7 @@ typedef struct AsyncSocket AsyncSocket;
@@ -51,23 +51,11 @@ index 46442e55..8bc66997 100644
#if defined(__cplusplus)
diff --git a/lib/include/poll.h b/lib/include/vm_poll.h
-similarity index 99%
-rename from a/lib/include/poll.h
-rename to a/lib/include/vm_poll.h
-index 988fe6d0..e9e74fb5 100644
---- a/lib/include/poll.h
-+++ b/lib/include/vm_poll.h
-@@ -60,7 +60,7 @@ extern "C" {
- #if !defined(TARGET_OS_IPHONE) || TARGET_OS_IPHONE == 0
- #include <sys/kernel.h>
- #endif
--#include <sys/poll.h>
-+#include <poll.h>
- #define HZ 100
- #endif
- #ifdef __ANDROID__
+similarity index 100%
+rename from lib/include/poll.h
+rename to lib/include/vm_poll.h
diff --git a/lib/rpcIn/rpcin.c b/lib/rpcIn/rpcin.c
-index c2c51583..d6c62f10 100644
+index 47a3380e..660382c6 100644
--- a/lib/rpcIn/rpcin.c
+++ b/lib/rpcIn/rpcin.c
@@ -57,7 +57,7 @@
@@ -79,16 +67,3 @@ index c2c51583..d6c62f10 100644
# include "asyncsocket.h"
# include "vmci_defs.h"
#include "dataMap.h"
-diff --git a/services/plugins/grabbitmqProxy/grabbitmqProxyPlugin.c b/services/plugins/grabbitmqProxy/grabbitmqProxyPlugin.c
-index 03700937..f0b49ad7 100644
---- a/services/plugins/grabbitmqProxy/grabbitmqProxyPlugin.c
-+++ b/services/plugins/grabbitmqProxy/grabbitmqProxyPlugin.c
-@@ -48,7 +48,7 @@
- #include "rpcout.h"
- #include "rabbitmqProxyConst.h"
- #include "vm_basic_types.h"
--#include "poll.h"
-+#include "vm_poll.h"
- #ifdef OPEN_VM_TOOLS
- #include "vmci_sockets.h"
- #include "sslDirect.h"