aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-05-05 15:31:38 -0700
committerRosen Penev <rosenp@gmail.com>2019-05-05 16:00:30 -0700
commit4639e208b3b159d8c85361682936b3941fb996b4 (patch)
tree59159e81d489f8603391fc5562aa597308794f1d /utils
parent5e28ab3effb4ebbaf5e324880af230b62267d0d9 (diff)
hfsprogs: Fix compilation with uClibc-ng
Replaced deprecated and unsupported valloc with posix_memalign. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/hfsprogs/Makefile2
-rw-r--r--utils/hfsprogs/patches/010-valloc-to-memalign.patch20
2 files changed, 21 insertions, 1 deletions
diff --git a/utils/hfsprogs/Makefile b/utils/hfsprogs/Makefile
index 9300fbc0a..e5184280e 100644
--- a/utils/hfsprogs/Makefile
+++ b/utils/hfsprogs/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=hfsprogs
PKG_VERSION:=332.25
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=GPL-3.0+
PKG_LICENSE_FILES:=COPYING
diff --git a/utils/hfsprogs/patches/010-valloc-to-memalign.patch b/utils/hfsprogs/patches/010-valloc-to-memalign.patch
new file mode 100644
index 000000000..c391e1dd5
--- /dev/null
+++ b/utils/hfsprogs/patches/010-valloc-to-memalign.patch
@@ -0,0 +1,20 @@
+--- a/newfs_hfs.tproj/makehfs.c
++++ b/newfs_hfs.tproj/makehfs.c
+@@ -376,7 +376,7 @@ make_hfsplus(const DriveInfo *driveInfo, hfsparams_t *defaults)
+ if ( (temp & 0x01FF) != 0 )
+ temp = (temp + kBytesPerSector) & 0xFFFFFE00;
+
+- nodeBuffer = valloc((size_t)temp);
++ (void)posix_memalign(&nodeBuffer, sysconf(_SC_PAGESIZE), (size_t)temp);
+ if (nodeBuffer == NULL)
+ err(1, NULL);
+
+@@ -1814,7 +1814,7 @@ ClearDisk(const DriveInfo *driveInfo, UInt64 startingSector, UInt32 numberOfSect
+
+ bufferSize = bufferSizeInSectors << kLog2SectorSize;
+
+- tempBuffer = valloc((size_t)bufferSize);
++ (void)posix_memalign(&tempBuffer, sysconf(_SC_PAGESIZE), (size_t)bufferSize);
+ if (tempBuffer == NULL)
+ err(1, NULL);
+