aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-12-07 15:20:58 -0800
committerGitHub <noreply@github.com>2020-12-07 15:20:58 -0800
commit44728d0557c191e9db26fe2c20eadd626003393e (patch)
treee457bf30417f5d57d85001a494a0fec95cfafb9f /utils
parent2d7cf6da69ff2e7fb164b8e2d8da92024f760059 (diff)
parentbd33076a23a7b7907002d83b038693f4889cfe5d (diff)
Merge pull request #14146 from neheb/summ
sumo: fix compilation with ccache
Diffstat (limited to 'utils')
-rw-r--r--utils/sumo/Makefile2
-rw-r--r--utils/sumo/patches/010-ccache.patch15
2 files changed, 16 insertions, 1 deletions
diff --git a/utils/sumo/Makefile b/utils/sumo/Makefile
index e467f9100..b5586de16 100644
--- a/utils/sumo/Makefile
+++ b/utils/sumo/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=sumo
PKG_VERSION:=1.7.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-src-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/sumo
diff --git a/utils/sumo/patches/010-ccache.patch b/utils/sumo/patches/010-ccache.patch
new file mode 100644
index 000000000..fb0b89aab
--- /dev/null
+++ b/utils/sumo/patches/010-ccache.patch
@@ -0,0 +1,15 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -29,12 +29,6 @@ project(SUMO)
+ set(PACKAGE_VERSION "1.7.0")
+ cmake_minimum_required(VERSION 3.1)
+
+-find_program(CCACHE_FOUND "ccache")
+-if (CCACHE_FOUND AND CCACHE_SUPPORT)
+- message(STATUS "Enabling ccache")
+- set_property(GLOBAL PROPERTY RULE_LAUNCH_COMPILE "ccache")
+-endif()
+-
+ set(CMAKE_COLOR_MAKEFILE ON)
+ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/build/cmake_modules/")
+