aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-08-07 00:21:56 -0700
committerGitHub <noreply@github.com>2019-08-07 00:21:56 -0700
commit3ee32eb9bccaa5705fec2a576911ac7f676aaea5 (patch)
tree627592191ca58dc606b568b7bcce97bf119ec467 /utils
parentb2f0cb973ecaf8a878f2d7b97fab96ce4e0bc302 (diff)
parentd6af6a4d75bd520510aaf2ef97b89024b427cac3 (diff)
Merge pull request #9574 from neheb/gdd
gddrescue: Add uClibc-ng support
Diffstat (limited to 'utils')
-rw-r--r--utils/gddrescue/Makefile4
-rw-r--r--utils/gddrescue/patches/010-fix-uclibcxx.patch102
2 files changed, 104 insertions, 2 deletions
diff --git a/utils/gddrescue/Makefile b/utils/gddrescue/Makefile
index 527fca23b..192c26500 100644
--- a/utils/gddrescue/Makefile
+++ b/utils/gddrescue/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gddrescue
PKG_VERSION:=1.23
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.xz
PKG_SOURCE_URL:=http://http.debian.net/debian/pool/main/g/$(PKG_NAME)
@@ -27,7 +27,7 @@ define Package/gddrescue
CATEGORY:=Utilities
TITLE:=Data recovery tool
URL:=https://www.gnu.org/software/ddrescue/
- DEPENDS:=$(CXX_DEPENDS) @!USE_UCLIBC
+ DEPENDS:=$(CXX_DEPENDS)
endef
define Package/gddrescue/description
diff --git a/utils/gddrescue/patches/010-fix-uclibcxx.patch b/utils/gddrescue/patches/010-fix-uclibcxx.patch
new file mode 100644
index 000000000..66e8e7671
--- /dev/null
+++ b/utils/gddrescue/patches/010-fix-uclibcxx.patch
@@ -0,0 +1,102 @@
+--- a/fillbook.cc
++++ b/fillbook.cc
+@@ -31,6 +31,9 @@
+ #include "block.h"
+ #include "mapbook.h"
+
++#ifdef __UCLIBCXX_MAJOR__
++#undef fputc
++#endif
+
+ // Return values: 1 write error, 0 OK.
+ //
+--- a/genbook.cc
++++ b/genbook.cc
+@@ -31,6 +31,9 @@
+ #include "block.h"
+ #include "mapbook.h"
+
++#ifdef __UCLIBCXX_MAJOR__
++#undef fputc
++#endif
+
+ const char * format_time( const long t, const bool low_prec )
+ {
+--- a/loggers.cc
++++ b/loggers.cc
+@@ -25,6 +25,9 @@
+ #include "block.h"
+ #include "loggers.h"
+
++#ifdef __UCLIBCXX_MAJOR__
++#undef fputc
++#endif
+
+ namespace {
+
+--- a/main.cc
++++ b/main.cc
+@@ -46,6 +46,11 @@
+ #include "non_posix.h"
+ #include "rescuebook.h"
+
++#ifdef __UCLIBCXX_MAJOR__
++#undef fgetc
++#undef fputc
++#endif
++
+ #ifndef O_BINARY
+ #define O_BINARY 0
+ #endif
+--- a/main_common.cc
++++ b/main_common.cc
+@@ -15,6 +15,10 @@
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
++#ifdef __UCLIBCXX_MAJOR__
++#undef fputc
++#endif
++
+ int verbosity = 0;
+
+ namespace {
+--- a/mapbook.cc
++++ b/mapbook.cc
+@@ -32,6 +32,10 @@
+ #include "block.h"
+ #include "mapbook.h"
+
++#ifdef __UCLIBCXX_MAJOR__
++#undef fgetc
++#undef fputc
++#endif
+
+ namespace {
+
+--- a/mapfile.cc
++++ b/mapfile.cc
+@@ -29,6 +29,11 @@
+
+ #include "block.h"
+
++#ifdef __UCLIBCXX_MAJOR__
++#undef fgetc
++#undef ferror
++#undef feof
++#endif
+
+ namespace {
+
+--- a/rescuebook.cc
++++ b/rescuebook.cc
+@@ -36,6 +36,9 @@
+ #include "mapbook.h"
+ #include "rescuebook.h"
+
++#ifdef __UCLIBCXX_MAJOR__
++#undef fputc
++#endif
+
+ namespace {
+