aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2020-03-09 14:59:29 +0100
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2020-03-09 15:19:36 +0100
commit3e2995aff2f0f4cb8bb5d8a91be27e8d7cb321ea (patch)
tree80975066312a6ebe533e6026924c148bc59efb58 /utils
parent1186e6d42733f2a2c700befe14718a4d9304263c (diff)
btrfs-progs: fix check for btrfs in btrfs scan
The previous implementation always succeeded so no scan was performed. This now fixes that and it correctly scans for BTRFS devices if BTRFS support is in kernel. Signed-off-by: Karel Kočí <karel.koci@nic.cz>
Diffstat (limited to 'utils')
-rw-r--r--utils/btrfs-progs/Makefile2
-rw-r--r--utils/btrfs-progs/files/btrfs-scan.init4
2 files changed, 4 insertions, 2 deletions
diff --git a/utils/btrfs-progs/Makefile b/utils/btrfs-progs/Makefile
index 6a8431fd2..bea3d033e 100644
--- a/utils/btrfs-progs/Makefile
+++ b/utils/btrfs-progs/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=btrfs-progs
PKG_VERSION:=5.4.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/kernel/people/kdave/btrfs-progs
diff --git a/utils/btrfs-progs/files/btrfs-scan.init b/utils/btrfs-progs/files/btrfs-scan.init
index 608d3d6c5..6b9ab62df 100644
--- a/utils/btrfs-progs/files/btrfs-scan.init
+++ b/utils/btrfs-progs/files/btrfs-scan.init
@@ -1,7 +1,9 @@
#!/bin/sh
preinit_btrfs_scan() {
- grep -vq btrfs /proc/filesystems || btrfs device scan
+ if grep -q btrfs /proc/filesystems; then
+ btrfs device scan
+ fi
}
boot_hook_add preinit_main preinit_btrfs_scan