aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-07-18 22:27:05 -0700
committerRosen Penev <rosenp@gmail.com>2021-07-20 19:49:52 -0700
commit3d8514b198555a43b021ec1a420706a6803fcfe6 (patch)
tree79763d8ec34f80be7455ce215b5a91198590bcd1 /utils
parent0b28914abb818b4ab793ec41ffd9e27fa55cb876 (diff)
yara: update to 4.1.1
Remove upstreamed patch. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/yara/Makefile4
-rw-r--r--utils/yara/patches/010-openssl.patch48
2 files changed, 2 insertions, 50 deletions
diff --git a/utils/yara/Makefile b/utils/yara/Makefile
index 9eae278c8..87fc2432b 100644
--- a/utils/yara/Makefile
+++ b/utils/yara/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=yara
-PKG_VERSION:=4.0.5
+PKG_VERSION:=4.1.1
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/VirusTotal/yara/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=ea7ebefad05831faf6f780cab721611b0135803f03a84c27eeba7bfe0afc3aae
+PKG_HASH:=5f85c69606fad5cdb42e8f8101c96f6962a4928667395d9471e5aaea961e9b1d
PKG_MAINTAINER:=Marko Ratkaj <marko.ratkaj@sartura.hr>
PKG_LICENSE:=BSD-3-Clause
diff --git a/utils/yara/patches/010-openssl.patch b/utils/yara/patches/010-openssl.patch
deleted file mode 100644
index a54b0001a..000000000
--- a/utils/yara/patches/010-openssl.patch
+++ /dev/null
@@ -1,48 +0,0 @@
---- a/libyara/include/yara/pe_utils.h
-+++ b/libyara/include/yara/pe_utils.h
-@@ -102,7 +102,7 @@ char *ord_lookup(
-
- #if HAVE_LIBCRYPTO
- #include <openssl/asn1.h>
--time_t ASN1_get_time_t(ASN1_TIME* time);
-+time_t ASN1_get_time_t(const ASN1_TIME* time);
- #endif
-
- #endif
---- a/libyara/modules/pe/pe.c
-+++ b/libyara/modules/pe/pe.c
-@@ -44,8 +44,8 @@ SOFTWARE, EVEN IF ADVISED OF THE POSSIBI
- #endif
-
- #if OPENSSL_VERSION_NUMBER < 0x10100000L
--#define X509_getm_notBefore X509_get_notBefore
--#define X509_getm_notAfter X509_get_notAfter
-+#define X509_get0_notBefore X509_get_notBefore
-+#define X509_get0_notAfter X509_get_notAfter
- #endif
- #endif
-
-@@ -1433,10 +1433,10 @@ void _parse_pkcs7(
- }
- }
-
-- date_time = ASN1_get_time_t(X509_get_notBefore(cert));
-+ date_time = ASN1_get_time_t(X509_get0_notBefore(cert));
- set_integer(date_time, pe->object, "signatures[%i].not_before", *counter);
-
-- date_time = ASN1_get_time_t(X509_get_notAfter(cert));
-+ date_time = ASN1_get_time_t(X509_get0_notAfter(cert));
- set_integer(date_time, pe->object, "signatures[%i].not_after", *counter);
-
- (*counter)++;
---- a/libyara/modules/pe/pe_utils.c
-+++ b/libyara/modules/pe/pe_utils.c
-@@ -307,7 +307,7 @@ time_t timegm(
- // and cleaned up. Also uses timegm(3) instead of mktime(3).
-
- time_t ASN1_get_time_t(
-- ASN1_TIME* time)
-+ const ASN1_TIME* time)
- {
- struct tm t;
- const char* str = (const char*) time->data;