aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-06-09 09:58:40 -0700
committerGitHub <noreply@github.com>2019-06-09 09:58:40 -0700
commit38dcd42b87a319433c7b546f928bfb55b5362b8e (patch)
tree1f0cd5b7599ebf6b8c52cf63f65854fb792b8a87 /utils
parent224841fababc28e6e26239e11af9c3a144a7419f (diff)
parent02a4ac87c0358a91ac613a2a18c35094d6ccf4bd (diff)
Merge pull request #9151 from neheb/po
powertop: Do not use fstack-protector on ARC
Diffstat (limited to 'utils')
-rw-r--r--utils/powertop/Makefile8
-rw-r--r--utils/powertop/patches/001-musl-fix-headers.patch22
2 files changed, 7 insertions, 23 deletions
diff --git a/utils/powertop/Makefile b/utils/powertop/Makefile
index 15a5881e4..4fa32c542 100644
--- a/utils/powertop/Makefile
+++ b/utils/powertop/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=powertop
PKG_VERSION:=2.10
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://01.org/sites/default/files/downloads/
@@ -39,8 +39,14 @@ define Package/powertop/description
and power management.
endef
+TARGET_CFLAGS += $(FPIC)
+ifeq ($(CONFIG_USE_UCLIBC),y)
+TARGET_CFLAGS += -fno-stack-protector
+endif
TARGET_LDFLAGS += $(if $(INTL_FULL),-lintl)
+CONFIGURE_ARGS += --without-pic
+
define Package/powertop/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/powertop \
diff --git a/utils/powertop/patches/001-musl-fix-headers.patch b/utils/powertop/patches/001-musl-fix-headers.patch
deleted file mode 100644
index 9839d15bf..000000000
--- a/utils/powertop/patches/001-musl-fix-headers.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- ./src/devices/devfreq.h.orig
-+++ ./src/devices/devfreq.h
-@@ -25,6 +25,7 @@
- #ifndef _INCLUDE_GUARD_DEVFREQ_H
- #define _INCLUDE_GUARD_DEVFREQ_H
-
-+#include <sys/time.h>
- #include "device.h"
- #include "../parameters/parameters.h"
-
-diff --git a/src/perf/perf.h b/src/perf/perf.h
-index ee072ae06d24..932588a684f9 100644
---- a/src/perf/perf.h
-+++ b/src/perf/perf.h
-@@ -26,6 +26,7 @@
- #define _INCLUDE_GUARD_PERF_H_
-
- #include <iostream>
-+#include <stdio.h>
-
-
- extern "C" {