aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2023-01-13 20:58:47 -0800
committerRosen Penev <rosenp@gmail.com>2023-01-14 19:47:36 -0800
commit365db936888d0ecfaf41bb00e10e8e43128cf7f1 (patch)
tree5c229901223c075ae3804e2f8d6919993dddd972 /utils
parentb6f7b2eabff057a8e04f2fdb7d5f61370d741c91 (diff)
pcsc-tools: update to 1.6.1
Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/pcsc-tools/Makefile6
-rw-r--r--utils/pcsc-tools/patches/001-disable-atr.patch6
2 files changed, 6 insertions, 6 deletions
diff --git a/utils/pcsc-tools/Makefile b/utils/pcsc-tools/Makefile
index 76ad65888..926801651 100644
--- a/utils/pcsc-tools/Makefile
+++ b/utils/pcsc-tools/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=pcsc-tools
-PKG_VERSION:=1.5.7
+PKG_VERSION:=1.6.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://ludovic.rousseau.free.fr/softwares/pcsc-tools/
-PKG_HASH:=e0ea8f8496d5bcf5316da913869ba95b925d0405c2aaade801c0d6ce7697699d
+PKG_SOURCE_URL:=http://ludovic.rousseau.free.fr/softwares/pcsc-tools
+PKG_HASH:=86fb756adfd18958d05af61e53c7503d4c46f0700677e6d0688dd4360eb53150
PKG_MAINTAINER:=
PKG_LICENSE:=GPL-2.0-or-later
diff --git a/utils/pcsc-tools/patches/001-disable-atr.patch b/utils/pcsc-tools/patches/001-disable-atr.patch
index fcca4cd1c..c5adda108 100644
--- a/utils/pcsc-tools/patches/001-disable-atr.patch
+++ b/utils/pcsc-tools/patches/001-disable-atr.patch
@@ -3,12 +3,12 @@ as a dependency.
--- a/pcsc_scan.c
+++ b/pcsc_scan.c
-@@ -241,7 +241,7 @@ static void initialize_options(options_t
- #ifdef WIN32
+@@ -294,7 +294,7 @@ static void initialize_options(options_t
+ #if defined(WIN32) || defined(__APPLE__)
options->analyse_atr = False;
#else
- options->analyse_atr = True;
+ options->analyse_atr = False;
#endif
options->stress_card = False;
- options->print_version = False;
+ options->maxtime = 0;