aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2023-12-20 10:00:08 +0100
committerHannu Nyman <hannu.nyman@iki.fi>2023-12-22 14:09:27 +0200
commit357fa2930c9de2f7041302083941421361536f5b (patch)
tree513c2c86764cb82bff2675e3a76d314c76fb8f32 /utils
parenta66fd0f835ae34c905ee5c53713d5cabc31f839e (diff)
mariadb: minor whitespace and typo fixes
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Diffstat (limited to 'utils')
-rw-r--r--utils/mariadb/Makefile2
-rw-r--r--utils/mariadb/files/mysqld.config5
-rw-r--r--utils/mariadb/files/mysqld.init42
3 files changed, 24 insertions, 25 deletions
diff --git a/utils/mariadb/Makefile b/utils/mariadb/Makefile
index 31806c2b1..f3aa65fec 100644
--- a/utils/mariadb/Makefile
+++ b/utils/mariadb/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mariadb
PKG_VERSION:=10.9.8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL := https://archive.mariadb.org/$(PKG_NAME)-$(PKG_VERSION)/source
diff --git a/utils/mariadb/files/mysqld.config b/utils/mariadb/files/mysqld.config
index e33adefc8..a0c0bedb7 100644
--- a/utils/mariadb/files/mysqld.config
+++ b/utils/mariadb/files/mysqld.config
@@ -1,13 +1,12 @@
config mysqld 'general'
# Unless enable, MariaDB will not start without this
- option enabled '0'
+ option enabled '0'
# User to run MariaDB as
option user 'mariadb'
# Group to run MariaDB
option group 'mariadb'
- # If there is now database, create an empty one automatically
+ # If there is no database, create an empty one automatically
option init '1'
# If upgrading old database, run mysql_upgrade during restart
option upgrade '1'
-
diff --git a/utils/mariadb/files/mysqld.init b/utils/mariadb/files/mysqld.init
index 52def2d3c..587ce95bf 100644
--- a/utils/mariadb/files/mysqld.init
+++ b/utils/mariadb/files/mysqld.init
@@ -147,7 +147,7 @@ start_service() {
# Migration from old versions
# shellcheck disable=SC2154
- if [ "$(cat "$datadir"/.version 2> /dev/null)" \!= "$version" ] && [ "$autoupgrade" -gt 0 ]; then
+ if [ "$(cat "$datadir"/.version 2> /dev/null)" \!= "$version" ] && [ "$autoupgrade" -gt 0 ]; then
# Check for correct owner
local owner="$(stat --format %U:%G "$datadir" 2> /dev/null)"
if [ -n "$owner" ] && [ "$owner" != "$my_user:$my_group" ]; then
@@ -155,34 +155,34 @@ start_service() {
fi
# Start upgrade instance without credentials
- sudo -u "$my_user" mysqld --skip-networking --skip-grant-tables --socket=/tmp/mysql_upgrade.sock &
+ sudo -u "$my_user" mysqld --skip-networking --skip-grant-tables --socket=/tmp/mysql_upgrade.sock &
PID="$!"
- i=0
+ i=0
# Wait for upgrade instance of db to start
- while [ "$i" -lt 15 ] && test \! -S /tmp/mysql_upgrade.sock; do
- sleep 1
- i="$((i + 1))"
- done
- [ -S /tmp/mysql_upgrade.sock ] || {
+ while [ "$i" -lt 15 ] && test \! -S /tmp/mysql_upgrade.sock; do
+ sleep 1
+ i="$((i + 1))"
+ done
+ [ -S /tmp/mysql_upgrade.sock ] || {
$LOGGER "Failed to start upgrading instance of MariaDB."
exit 1
}
# Upgrade the database
- mysql_upgrade --upgrade-system-tables --socket=/tmp/mysql_upgrade.sock
- echo "$version" > "$datadir"/.version
+ mysql_upgrade --upgrade-system-tables --socket=/tmp/mysql_upgrade.sock
+ echo "$version" > "$datadir"/.version
# Stop the upgrade instance
- kill "$PID"
- i=0
- while [ "$i" -lt 60 ] && grep -q mysql "/proc/$PID/cmdline"; do
- sleep 1
- [ "$i" -lt 30 ] || kill "$PID"
- i="$((i + 1))"
- done
+ kill "$PID"
+ i=0
+ while [ "$i" -lt 60 ] && grep -q mysql "/proc/$PID/cmdline"; do
+ sleep 1
+ [ "$i" -lt 30 ] || kill "$PID"
+ i="$((i + 1))"
+ done
# Use force
- if grep -q mysql "/proc/$PID/cmdline"; then
- kill -9 "$PID"
- fi
- fi
+ if grep -q mysql "/proc/$PID/cmdline"; then
+ kill -9 "$PID"
+ fi
+ fi
# Start daemon
procd_open_instance