aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2015-08-26 21:35:35 +0300
committerHannu Nyman <hannu.nyman@iki.fi>2015-08-26 21:35:35 +0300
commit35552db4ee8162b5c85f2a9e370177681a70431c (patch)
tree4360708c183b3d9b5906699acdea717897a4af46 /utils
parentdb05302eab48b4429296fc88a5966529a547df8a (diff)
collectd: Enable entropy plugin
Enable the entropy plugin that monitors the available entropy in a Linux system. Works ok and has no library dependencies. Tested on ar71xx/WNDR3700. Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Diffstat (limited to 'utils')
-rw-r--r--utils/collectd/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/utils/collectd/Makefile b/utils/collectd/Makefile
index 3bb19730c..74d305b46 100644
--- a/utils/collectd/Makefile
+++ b/utils/collectd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=collectd
PKG_VERSION:=5.5.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://collectd.org/files/
@@ -36,7 +36,6 @@ COLLECTD_PLUGINS_DISABLED:= \
curl_xml \
dbi \
drbd \
- entropy \
ethstat \
fhcount \
genericjmx \
@@ -109,6 +108,7 @@ COLLECTD_PLUGINS_SELECTED:= \
disk \
dns \
email \
+ entropy \
exec \
filecount \
fscache \
@@ -300,6 +300,7 @@ $(eval $(call BuildPlugin,df,disk space input,df,))
$(eval $(call BuildPlugin,disk,disk usage/timing input,disk,))
$(eval $(call BuildPlugin,dns,DNS traffic input,dns,+PACKAGE_collectd-mod-dns:libpcap))
$(eval $(call BuildPlugin,email,email output,email,))
+$(eval $(call BuildPlugin,entropy,Entropy amount input,entropy,))
$(eval $(call BuildPlugin,exec,process exec input,exec,))
$(eval $(call BuildPlugin,filecount,file count input,filecount,))
$(eval $(call BuildPlugin,fscache,file-system based caching framework input,fscache,))