aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2023-01-14 14:34:54 -0800
committerRosen Penev <rosenp@gmail.com>2023-01-14 19:37:45 -0800
commit3218dd24577b051fddb1635a5a856fe8426ef8f8 (patch)
treeb90b996616555034ad512861dca028cc98a3ac74 /utils
parent2fa8db3c3c508a0c9244d02623058a9db03d42df (diff)
stress: update to 1.0.5
New upstream. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/stress/Makefile22
-rw-r--r--utils/stress/patches/010-usleep.patch10
2 files changed, 14 insertions, 18 deletions
diff --git a/utils/stress/Makefile b/utils/stress/Makefile
index 3a66817dd..953b21cd5 100644
--- a/utils/stress/Makefile
+++ b/utils/stress/Makefile
@@ -8,17 +8,20 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=stress
-PKG_VERSION:=1.0.4
-PKG_RELEASE:=2
+PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://fossies.org/linux/privat
-PKG_HASH:=369c997f65e8426ae8b318d4fdc8e6f07a311cfa77cc4b25dace465c582163c0
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_VERSION:=1.0.5
+PKG_SOURCE_URL:=https://github.com/resurrecting-open-source-projects/stress
+PKG_MIRROR_HASH:=711e42ead6fd220a98821aae0cf024930785e439d3d0d50663fed1b2cd021bd1
-PKG_LICENSE:=GPL-2.0
+PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
+PKG_LICENSE:=GPL-2.0-only
PKG_LICENSE_FILES:=COPYING
+PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
@@ -27,7 +30,6 @@ define Package/stress
CATEGORY:=Utilities
TITLE:=stress is a simple stress utility
URL:=
- MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
endef
define Package/stress/description
@@ -35,12 +37,6 @@ stress is a simple tool that imposes certain types of compute \ stress on
UNIX-like operating systems.
endef
-CONFIGURE_ARGS += \
- --prefix="/usr"
-
-MAKE_FLAGS += \
- CFLAGS="$(TARGET_CFLAGS)"
-
define Package/stress/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/stress $(1)/usr/bin/
diff --git a/utils/stress/patches/010-usleep.patch b/utils/stress/patches/010-usleep.patch
index 69467264c..fde51cf85 100644
--- a/utils/stress/patches/010-usleep.patch
+++ b/utils/stress/patches/010-usleep.patch
@@ -1,6 +1,6 @@
--- a/src/stress.c
+++ b/src/stress.c
-@@ -262,6 +262,7 @@ main (int argc, char **argv)
+@@ -263,6 +263,7 @@ main (int argc, char **argv)
/* Calculate the backoff value so we get good fork throughput. */
backoff = do_backoff * forks;
@@ -8,7 +8,7 @@
dbg (stdout, "using backoff sleep of %llius\n", backoff);
/* If we are supposed to respect a timeout, calculate it. */
-@@ -296,7 +297,7 @@ main (int argc, char **argv)
+@@ -297,7 +298,7 @@ main (int argc, char **argv)
{
case 0: /* child */
alarm (timeout);
@@ -17,7 +17,7 @@
if (do_dryrun)
exit (0);
exit (hogcpu ());
-@@ -317,7 +318,7 @@ main (int argc, char **argv)
+@@ -318,7 +319,7 @@ main (int argc, char **argv)
{
case 0: /* child */
alarm (timeout);
@@ -26,7 +26,7 @@
if (do_dryrun)
exit (0);
exit (hogio ());
-@@ -337,7 +338,7 @@ main (int argc, char **argv)
+@@ -338,7 +339,7 @@ main (int argc, char **argv)
{
case 0: /* child */
alarm (timeout);
@@ -35,7 +35,7 @@
if (do_dryrun)
exit (0);
exit (hogvm
-@@ -358,7 +359,7 @@ main (int argc, char **argv)
+@@ -359,7 +360,7 @@ main (int argc, char **argv)
{
case 0: /* child */
alarm (timeout);