aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2019-05-03 01:17:12 +0800
committerJeffery To <jeffery.to@gmail.com>2019-05-03 01:17:12 +0800
commit2f5a79cdc278603bb972ccbdf78224d812a658ed (patch)
tree52f815b017aa0fcba23a40b7e230b9977ce0e35d /utils
parentb57a79dd2c6ab1a07a4d63b74be2bc40753bcf83 (diff)
xz: Use relative paths in pkg-config metadata file
By default, the liblzma pkg-config file (liblzma.pc) is generated with absolute paths, which $(STAGING_DIR_HOST)/bin/pkg-config is unable to override. This patches the file to use paths relative to ${prefix} and ${exec_prefix}. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/xz/Makefile2
-rw-r--r--utils/xz/patches/001-relative-pkg-config-paths.patch13
2 files changed, 14 insertions, 1 deletions
diff --git a/utils/xz/Makefile b/utils/xz/Makefile
index 7b8088354..0b94e5bdd 100644
--- a/utils/xz/Makefile
+++ b/utils/xz/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=xz
PKG_VERSION:=5.2.4
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/lzmautils
diff --git a/utils/xz/patches/001-relative-pkg-config-paths.patch b/utils/xz/patches/001-relative-pkg-config-paths.patch
new file mode 100644
index 000000000..b89c13f75
--- /dev/null
+++ b/utils/xz/patches/001-relative-pkg-config-paths.patch
@@ -0,0 +1,13 @@
+--- a/src/liblzma/liblzma.pc.in
++++ b/src/liblzma/liblzma.pc.in
+@@ -7,8 +7,8 @@
+
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
+-libdir=@libdir@
+-includedir=@includedir@
++libdir=${exec_prefix}/lib
++includedir=${prefix}/include
+
+ Name: liblzma
+ Description: General purpose data compression library