aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-07-20 20:49:13 -0700
committerRosen Penev <rosenp@gmail.com>2021-07-23 19:50:27 -0700
commit2e6de9371024294067bb747ab2633fee4b315af4 (patch)
tree9096f070a2d2d4f509a56e0b8d8a81d9d0ff2c56 /utils
parenta76dc4ac5c364d28ae8f01fa1f3f5b24293f8007 (diff)
minicom: update to 2.8
Switch URL to new upstream. Switch to AUTORELEASE for simplicity. Removed most patches as they have been upstreamed. Rebased the remaining one. Fixed license information. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/minicom/Makefile14
-rw-r--r--utils/minicom/patches/100-fix_iconv_include.patch12
-rw-r--r--utils/minicom/patches/101-fix_music_includes.patch14
-rw-r--r--utils/minicom/patches/102-fix_musl_compatibility.patch13
-rw-r--r--utils/minicom/patches/110-reproducible-builds.patch14
-rw-r--r--utils/minicom/patches/200-gcc10.patch30
6 files changed, 14 insertions, 83 deletions
diff --git a/utils/minicom/Makefile b/utils/minicom/Makefile
index f21650191..bc40b4e05 100644
--- a/utils/minicom/Makefile
+++ b/utils/minicom/Makefile
@@ -8,15 +8,15 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=minicom
-PKG_VERSION:=2.7.1
-PKG_RELEASE:=2
+PKG_VERSION:=2.8
+PKG_RELEASE:=$(AUTORELEASE)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://alioth.debian.org/frs/download.php/file/4215
-PKG_HASH:=532f836b7a677eb0cb1dca8d70302b73729c3d30df26d58368d712e5cca041f1
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=https://salsa.debian.org/minicom-team/minicom/-/archive/$(PKG_VERSION)
+PKG_HASH:=38cea30913a20349326ff3f1763ee1512b7b41601c24f065f365e18e9db0beba
PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
-PKG_LICENSE:=GPL-2.0
+PKG_LICENSE:=GPL-2.0-or-later
PKG_LICENSE_FILES:=COPYING
PKG_CPE_ID:=cpe:/a:minicom:minicom
@@ -30,7 +30,7 @@ define Package/minicom
CATEGORY:=Utilities
DEPENDS:=$(ICONV_DEPENDS) $(INTL_DEPENDS) +libncurses
TITLE:=Terminal emulation program
- URL:=http://alioth.debian.org/projects/minicom/
+ URL:=https://salsa.debian.org/minicom-team/minicom
SUBMENU:=Terminal
endef
diff --git a/utils/minicom/patches/100-fix_iconv_include.patch b/utils/minicom/patches/100-fix_iconv_include.patch
deleted file mode 100644
index 88190faae..000000000
--- a/utils/minicom/patches/100-fix_iconv_include.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/src/minicom.c
-+++ b/src/minicom.c
-@@ -31,7 +31,9 @@
- #include <getopt.h>
- #include <wchar.h>
- #include <wctype.h>
-+#ifdef HAVE_ICONV
- #include <iconv.h>
-+#endif
- #include <limits.h>
-
- #define EXTERN
diff --git a/utils/minicom/patches/101-fix_music_includes.patch b/utils/minicom/patches/101-fix_music_includes.patch
deleted file mode 100644
index a74d1233d..000000000
--- a/utils/minicom/patches/101-fix_music_includes.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/src/dial.c
-+++ b/src/dial.c
-@@ -39,11 +39,9 @@
- #include "intl.h"
-
- #ifdef VC_MUSIC
--# if defined(__GLIBC__)
- # include <sys/ioctl.h>
- # include <sys/kd.h>
- # include <sys/time.h>
--# endif
- #endif
-
- enum { CURRENT_VERSION = 6 };
diff --git a/utils/minicom/patches/102-fix_musl_compatibility.patch b/utils/minicom/patches/102-fix_musl_compatibility.patch
deleted file mode 100644
index 4524b22d8..000000000
--- a/utils/minicom/patches/102-fix_musl_compatibility.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/src/getsdir.h
-+++ b/src/getsdir.h
-@@ -24,6 +24,10 @@
-
- #include <dirent.h>
-
-+#ifndef MAXNAMLEN
-+#define MAXNAMLEN 255
-+#endif
-+
- typedef struct dirEntry { /* structure of data item */
- char fname[MAXNAMLEN + 1]; /* filename + terminating null */
- time_t time; /* last modification date */
diff --git a/utils/minicom/patches/110-reproducible-builds.patch b/utils/minicom/patches/110-reproducible-builds.patch
index 1302f5b81..82aaa1355 100644
--- a/utils/minicom/patches/110-reproducible-builds.patch
+++ b/utils/minicom/patches/110-reproducible-builds.patch
@@ -1,15 +1,15 @@
--- a/src/minicom.c
+++ b/src/minicom.c
-@@ -1161,7 +1161,7 @@ int main(int argc, char **argv)
+@@ -1248,7 +1248,7 @@ int main(int argc, char **argv)
switch(c) {
- case 'v':
- printf(_("%s version %s"), PACKAGE, VERSION);
+ case 'v':
+ printf(_("%s version %s"), PACKAGE, VERSION);
-#ifdef __DATE__
-+#if 0
- printf(_(" (compiled %s)"), __DATE__);
++#if 0
+ printf(_(" (compiled %s)"), __DATE__);
#endif
- printf("\n");
-@@ -1464,7 +1464,7 @@ int main(int argc, char **argv)
+ printf("\n");
+@@ -1580,7 +1580,7 @@ int main(int argc, char **argv)
mc_wprintf(us, "\n%s %s\r\n", _("Welcome to minicom"), VERSION);
mc_wprintf(us, "\n%s: %s\r\n", _("OPTIONS"), option_string);
diff --git a/utils/minicom/patches/200-gcc10.patch b/utils/minicom/patches/200-gcc10.patch
deleted file mode 100644
index 987e16e1a..000000000
--- a/utils/minicom/patches/200-gcc10.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/src/minicom.h
-+++ b/src/minicom.h
-@@ -109,13 +109,13 @@ EXTERN char *dial_tty; /* tty to use
-
- EXTERN char *dial_name; /* System we're conneced to */
- EXTERN char *dial_number; /* Number we've dialed. */
--EXTERN char *dial_user; /* Our username there */
--EXTERN char *dial_pass; /* Our password */
-+extern char *dial_user; /* Our username there */
-+extern char *dial_pass; /* Our password */
-
- #ifdef USE_SOCKET
--EXTERN int portfd_is_socket; /* File descriptor is a unix socket */
--EXTERN int portfd_is_connected; /* 1 if the socket is connected */
--EXTERN struct sockaddr_un portfd_sock_addr; /* the unix socket address */
-+extern int portfd_is_socket; /* File descriptor is a unix socket */
-+extern int portfd_is_connected; /* 1 if the socket is connected */
-+extern struct sockaddr_un portfd_sock_addr; /* the unix socket address */
- #define portfd_connected ((portfd_is_socket && !portfd_is_connected) \
- ? -1 : portfd)
- #else
-@@ -141,7 +141,7 @@ EXTERN int sbcolor; /* Status Bar Ba
- EXTERN int st_attr; /* Status Bar attributes. */
-
- /* jl 04.09.97 conversion tables */
--EXTERN unsigned char vt_outmap[256], vt_inmap[256];
-+extern unsigned char vt_outmap[256], vt_inmap[256];
-
- /* MARK updated 02/17/95 - history buffer */
- EXTERN int num_hist_lines; /* History buffer size */