aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-02-29 13:38:14 -0800
committerRosen Penev <rosenp@gmail.com>2020-03-01 16:31:08 -0800
commit26b32aceee033fdf9b27ad61747419e8a0b58e42 (patch)
treea36b7131c5dc8cac9225d840d0f6aa7c93df35e2 /utils
parent0afea2e06bbd2885218f1dfe7d6b50f9bc399a43 (diff)
smartmontools: convert init script to procd
Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/smartmontools/Makefile2
-rw-r--r--utils/smartmontools/files/smartd.init16
2 files changed, 10 insertions, 8 deletions
diff --git a/utils/smartmontools/Makefile b/utils/smartmontools/Makefile
index ee1feff33..5d9797699 100644
--- a/utils/smartmontools/Makefile
+++ b/utils/smartmontools/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/uclibc++.mk
PKG_NAME:=smartmontools
PKG_VERSION:=7.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/smartmontools
diff --git a/utils/smartmontools/files/smartd.init b/utils/smartmontools/files/smartd.init
index f1453f257..ae849adde 100644
--- a/utils/smartmontools/files/smartd.init
+++ b/utils/smartmontools/files/smartd.init
@@ -3,14 +3,16 @@
START=95
-start() {
- service_start /usr/sbin/smartd -q never
-}
+USE_PROCD=1
+PROG=/usr/sbin/smartd
-stop() {
- service_stop /usr/sbin/smartd
+start_service() {
+ procd_open_instance
+ procd_set_param command "$PROG"
+ procd_append_param command -n -q never
+ procd_close_instance
}
-reload() {
- service_reload /usr/sbin/smartd
+reload_service() {
+ procd_send_signal smartd
}