aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorJavier Marcet <javier@marcet.info>2024-03-30 16:59:10 +0100
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2024-03-31 13:06:42 +0200
commit261b38c14bed7865d244f24d0adb1bb33e963b88 (patch)
treea44c0ed593a6e089015a06537113f1debeba6fc0 /utils
parent9db6b4ababa9c9ee751d627ac00386fe9bfe7b7a (diff)
docker-compose: add PKG_NAME to PKG_SOURCE
Before this change, the tarball was downloaded as vVERSION.tar.gz. For example, it was v2.26.1.tar.gz and that file was put into the dl folder within the OpenWrt build system. After this change, the tarball is properly downloaded as NAME-vVERSION.tar.gz. In this case, it will look like this: docker-compose-v.2.26.1.tar.gz The advantages of using this: - Users, developers will know that what they downloaded (it has name and version) - The tarball will not be overwritten by another package with the same version. Signed-off-by: Javier Marcet <javier@marcet.info> Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com> [added commit message]
Diffstat (limited to 'utils')
-rw-r--r--utils/docker-compose/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/utils/docker-compose/Makefile b/utils/docker-compose/Makefile
index 81c74fa1e..621a6134a 100644
--- a/utils/docker-compose/Makefile
+++ b/utils/docker-compose/Makefile
@@ -2,11 +2,11 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=compose
PKG_VERSION:=2.26.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=Apache-2.0
PKG_LICENSE_FILES:=LICENSE
-PKG_SOURCE:=v$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/docker/compose/tar.gz/v${PKG_VERSION}?
PKG_HASH:=081ad40241f8e144cad088a65e6fd0ec588e3d36931e5baabb3dc5ab068ceb60