aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-10-18 15:28:43 -0700
committerRosen Penev <rosenp@gmail.com>2019-10-18 15:28:43 -0700
commit238d6e1f9010cf009ead3797cba2042cb8ce425e (patch)
tree0e2491bb67fa120554eaf2ca5515a153ac125a6f /utils
parent50965099458b689b60201658aae4bcb15ef34a1b (diff)
sispmctl: Reduce ipk size
Do not install static libraries or symlinks as actual files. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/sispmctl/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/utils/sispmctl/Makefile b/utils/sispmctl/Makefile
index 2d8fb3478..bc9adaccd 100644
--- a/utils/sispmctl/Makefile
+++ b/utils/sispmctl/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=sispmctl
PKG_VERSION:=4.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
@@ -51,14 +51,13 @@ define Package/sispmctl/description
multiple SIS-PM devices, too.
endef
-TARGET_CFLAGS += -D_GNU_SOURCE
CONFIGURE_ARGS += \
--enable-webless \
--disable-dependency-tracking
define Package/libsispmctl/install
$(INSTALL_DIR) $(1)/usr/lib
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libsispmctl* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsispmctl.so* $(1)/usr/lib/
endef
define Package/sispmctl/install