aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-08-05 12:01:38 -0700
committerGitHub <noreply@github.com>2019-08-05 12:01:38 -0700
commit21a0ff74f5f27a3420febff33c48a08120f1df44 (patch)
tree6134e89b1c3f269d9f5dbfc9babe91ffa67e9aae /utils
parent2e6328494eb9321c4c020bbd518884e588a7c1c3 (diff)
parent4cda68c72b54885e0465411ba8667e543771d2e2 (diff)
Merge pull request #9635 from neheb/jhfehkf
mt-st: Add missing header
Diffstat (limited to 'utils')
-rw-r--r--utils/mt-st/Makefile8
-rw-r--r--utils/mt-st/patches/010-sysmacros.patch10
2 files changed, 13 insertions, 5 deletions
diff --git a/utils/mt-st/Makefile b/utils/mt-st/Makefile
index aab5e751e..71bfdcf99 100644
--- a/utils/mt-st/Makefile
+++ b/utils/mt-st/Makefile
@@ -9,14 +9,13 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mt-st
PKG_VERSION:=1.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)
-PKG_SOURCE_VERSION:=$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://ftp.ibiblio.org/pub/Linux/system/backup/
PKG_HASH:=945cb4f3d9957dabe768f5941a9148b746396836c797b25f020c84319ba8170d
+PKG_MAINTAINER:=Giuseppe Magnotta <giuseppe.magnotta@gmail.com>
PKG_LICENSE:=GPL-2.0
include $(INCLUDE_DIR)/package.mk
@@ -26,7 +25,6 @@ define Package/mt-st
CATEGORY:=Utilities
TITLE:=Magnetic tape control tools for Linux SCSI tapes
URL:=http://ftp.ibiblio.org/pub/Linux/system/backup/
- MAINTAINER:=Giuseppe Magnotta <giuseppe.magnotta@gmail.com>
endef
define Package/mt-st/description
diff --git a/utils/mt-st/patches/010-sysmacros.patch b/utils/mt-st/patches/010-sysmacros.patch
new file mode 100644
index 000000000..8e4b37378
--- /dev/null
+++ b/utils/mt-st/patches/010-sysmacros.patch
@@ -0,0 +1,10 @@
+--- a/mt.c
++++ b/mt.c
+@@ -21,6 +21,7 @@
+ #include <sys/types.h>
+ #include <sys/ioctl.h>
+ #include <sys/stat.h>
++#include <sys/sysmacros.h>
+ #include <sys/utsname.h>
+
+ #include "mtio.h"