aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2024-04-04 02:59:17 +0100
committerDaniel Golle <daniel@makrotopia.org>2024-04-04 03:58:39 +0100
commit20cc530004d84c631a6d11fde0cf3dd8f55d34a3 (patch)
tree5fefa4ea60d50b591ab2e57823de8af2583d6508 /utils
parent65007588057ee724b37b4187b0a2e508a41b5884 (diff)
lvm2: update to LVM2 2.03.17 and libdm Version 1.02.187
LVM2 Version 2.03.17 - 10th November 2022 ========================================= Add new options (--fs, --fsmode) for FS handling when resizing LVs. Fix 'lvremove -S|--select LV' to not also remove its historical LV right away. Fix lv_active field type to binary so --select and --binary applies properly. Switch to use mallinfo2 and use it only with glibc. Error out in lvm shell if using a cmd argument not supported in the shell. Fix lvm shell's lastlog command to report previous pre-command failures. Extend VDO and VDOPOOL without flushing and locking fs. Add --valuesonly option to lvmconfig to print only values without keys. Updates configure with recent autoconf tooling. Fix lvconvert --test --type vdo-pool execution. Add json_std output format for more JSON standard compliant version of output. Fix vdo_slab_size_mb value for converted VDO volume. Fix many corner cases in device_id, including handling of S/N duplicates. Fix various issues in lvmdbusd. DM Version 1.02.187 - 10th November 2022 ======================================== Add DM_REPORT_GROUP_JSON_STD for more JSON standard compliant output format. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'utils')
-rw-r--r--utils/lvm2/Makefile6
-rw-r--r--utils/lvm2/patches/002-const-stdio.patch8
2 files changed, 7 insertions, 7 deletions
diff --git a/utils/lvm2/Makefile b/utils/lvm2/Makefile
index dc5239b68..42cc59a31 100644
--- a/utils/lvm2/Makefile
+++ b/utils/lvm2/Makefile
@@ -9,13 +9,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=LVM2
-PKG_VERSION:=2.03.22
-PKG_VERSION_DM:=1.02.196
+PKG_VERSION:=2.03.23
+PKG_VERSION_DM:=1.02.197
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
PKG_SOURCE_URL:=https://sourceware.org/pub/lvm2
-PKG_HASH:=4c5a6923bd1ace7ce04474608a84937ce053ba91b1ace9f0b0017268e732dc7c
+PKG_HASH:=74e794a9e9dee1bcf8a2065f65b9196c44fdf321e22d63b98ed7de8c9aa17a5d
PKG_BUILD_DIR:=$(BUILD_DIR)/lvm2-$(BUILD_VARIANT)/$(PKG_NAME).$(PKG_VERSION)
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
diff --git a/utils/lvm2/patches/002-const-stdio.patch b/utils/lvm2/patches/002-const-stdio.patch
index b6ed24449..975065923 100644
--- a/utils/lvm2/patches/002-const-stdio.patch
+++ b/utils/lvm2/patches/002-const-stdio.patch
@@ -1,6 +1,6 @@
--- a/lib/commands/toolcontext.c
+++ b/lib/commands/toolcontext.c
-@@ -1667,7 +1667,7 @@ struct cmd_context *create_toolcontext(u
+@@ -1709,7 +1709,7 @@ struct cmd_context *create_toolcontext(u
/* FIXME Make this configurable? */
reset_lvm_errno(1);
@@ -9,7 +9,7 @@
/* Set in/out stream buffering before glibc */
if (set_buffering
#ifdef SYS_gettid
-@@ -2043,7 +2043,7 @@ void destroy_toolcontext(struct cmd_cont
+@@ -2085,7 +2085,7 @@ void destroy_toolcontext(struct cmd_cont
dm_hash_destroy(cmd->cft_def_hash);
dm_device_list_destroy(&cmd->cache_dm_devs);
@@ -20,7 +20,7 @@
if (is_valid_fd(STDIN_FILENO) &&
--- a/tools/lvmcmdline.c
+++ b/tools/lvmcmdline.c
-@@ -3432,6 +3432,7 @@ int lvm_split(char *str, int *argc, char
+@@ -3437,6 +3437,7 @@ int lvm_split(char *str, int *argc, char
/* Make sure we have always valid filedescriptors 0,1,2 */
static int _check_standard_fds(void)
{
@@ -28,7 +28,7 @@
int err = is_valid_fd(STDERR_FILENO);
if (!is_valid_fd(STDIN_FILENO) &&
-@@ -3458,6 +3459,12 @@ static int _check_standard_fds(void)
+@@ -3463,6 +3464,12 @@ static int _check_standard_fds(void)
strerror(errno));
return 0;
}