aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorPaul Fertser <fercerpav@gmail.com>2023-01-20 14:54:59 +0000
committerRosen Penev <rosenp@gmail.com>2023-01-20 17:44:14 -0800
commit1e8584dc581567d12c9f4fcb1e1dd29b7a189ae9 (patch)
tree1efeeb89db6debb67e3e750fc8636925df0c1a7e /utils
parentdd48483a60080ea5f3b83d5d4c71a9ac7b27043b (diff)
treewide: quote CC and CXX
When CC is set to e.g. "ccache mips-openwrt-linux-musl-gcc" it needs to be quoted to avoid word splitting on substitution. Signed-off-by: Paul Fertser <fercerpav@gmail.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/ctop/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/utils/ctop/Makefile b/utils/ctop/Makefile
index 69268008b..65180fad6 100644
--- a/utils/ctop/Makefile
+++ b/utils/ctop/Makefile
@@ -38,8 +38,8 @@ MAKE_VARS += \
GOPATH=$(GO_PKG_BUILD_DIR) \
GOCACHE=$(GO_BUILD_CACHE_DIR) \
GOROOT_FINAL=$(GO_TARGET_ROOT) \
- CC=$(TARGET_CC) \
- CXX=$(TARGET_CXX) \
+ CC="$(TARGET_CC)" \
+ CXX="$(TARGET_CXX)" \
$(GO_PKG_VARS)
MAKE_FLAGS += \
COMMIT=$(PKG_SOURCE_VERSION)