aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-06-08 08:32:13 -0700
committerGitHub <noreply@github.com>2019-06-08 08:32:13 -0700
commit1c4b6fef5f57364d65fda1c1e072cc960e9d3dfb (patch)
tree3f611ca99608722edfb059732ef5c3625a4009b0 /utils
parent758b36898561156578ef1bd697bcc435daecf055 (diff)
parentc005595e09a20db0adee415839732aab71688b8f (diff)
Merge pull request #9191 from neheb/pciu
pciutils: Install libpci using CP instead of INSTALL_BIN
Diffstat (limited to 'utils')
-rw-r--r--utils/pciutils/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/utils/pciutils/Makefile b/utils/pciutils/Makefile
index b5661c407..ed287eeff 100644
--- a/utils/pciutils/Makefile
+++ b/utils/pciutils/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=pciutils
PKG_VERSION:=3.6.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/software/utils/pciutils
@@ -43,17 +43,16 @@ define Package/libpci
CATEGORY:=Libraries
TITLE:=Linux PCI Libraries
URL:=http://mj.ucw.cz/pciutils.shtml
- DEPENDS:=
endef
-PCI_IDS_VER:=0.319
+PCI_IDS_VER:=0.324
PCI_IDS_FILE:=pci.ids.$(PCI_IDS_VER)
define Download/pci_ids
FILE:=$(PCI_IDS_FILE)
URL_FILE:=pci.ids
URL:=@GITHUB/vcrhonek/hwdata/v$(PCI_IDS_VER)
- HASH:=54154a6955f550b110c6a216943dcd69ba6188e68b80bee6efbaa03ef0df0a5f
+ HASH:=6dba287b4aaafb9582d6139eda22ee6580651b8557828b9598d99078a5f4217e
endef
$(eval $(call Download,pci_ids))
@@ -98,7 +97,7 @@ endef
define Package/libpci/install
$(INSTALL_DIR) $(1)/usr/lib
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
endef