aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2021-07-18 17:40:47 +0200
committerDavid Bauer <mail@david-bauer.net>2021-08-01 13:09:39 +0200
commit1588ee3c3cf2676898fce3eabdff815641380607 (patch)
treefe1963ad6113491349904878098b9dfc5b910369 /utils
parent2abbf288ed5cabd024706ec8dad2dfb74ca4e620 (diff)
clocate: add package
clocate is a small utility to determinethe location of a 802.11 capable device by using a remote locator service (Mozilla or Google). Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'utils')
-rw-r--r--utils/clocate/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/utils/clocate/Makefile b/utils/clocate/Makefile
new file mode 100644
index 000000000..424f75e97
--- /dev/null
+++ b/utils/clocate/Makefile
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2021 David Bauer <mail@david-bauer.net>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=clocate
+PKG_SOURCE_DATE:=2021-07-07
+PKG_RELEASE:=$(AUTORELEASE)
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/blocktrron/clocate.git
+PKG_SOURCE_VERSION:=ef531687c16bab959f61dff3755148ac9a0c1464
+PKG_MIRROR_HASH:=1fde4052113a52c018476062a5fad656673b89be95a469fed2d35649a7f1bce3
+
+PKG_MAINTAINER:=David Bauer <mail@david-bauer.net>
+PKG_LICENSE:=GPL-2.0-only
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/clocate
+ SECTION:=utils
+ CATEGORY:=Utilities
+ DEPENDS:=+libcurl +libnl-tiny +libjson-c
+ TITLE:=Determine device location using neighbouring WiFi networks
+endef
+
+define Package/clocate/description
+ This program can locate a device by sending the nighbouring WiFI networks
+ to a geolocation Provider. Currently supported providers are Mozilla and Google.
+endef
+
+define Package/clocate/install
+ $(INSTALL_DIR) $(1)/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/clocate $(1)/sbin/clocate
+endef
+
+MAKE_FLAGS += LIBNL_TINY=1
+
+$(eval $(call BuildPackage,clocate))