aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorOskari Rauta <oskari.rauta@gmail.com>2023-01-11 12:57:38 +0200
committerTianling Shen <cnsztl@gmail.com>2023-01-11 19:52:45 +0800
commit1394035a392050df9d00a1b4313f8bea9f352b55 (patch)
tree9b174ae2739e57c80dbbc1c75eb089527a0ed22b /utils
parentad0aa1b2fc64e89b1d055ec55419798701e86fe1 (diff)
conmon: update to 2.1.5
Signed-off-by: Oskari Rauta <oskari.rauta@gmail.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/conmon/Makefile6
-rw-r--r--utils/conmon/patches/010-remove-libdl-dep.patch21
2 files changed, 6 insertions, 21 deletions
diff --git a/utils/conmon/Makefile b/utils/conmon/Makefile
index ef500a836..887511ab9 100644
--- a/utils/conmon/Makefile
+++ b/utils/conmon/Makefile
@@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=conmon
-PKG_VERSION:=2.1.0
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_VERSION:=2.1.5
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/containers/$(PKG_NAME)/archive/v$(PKG_VERSION)
-PKG_HASH:=874909d831feac75e452562087f6ea0eb39848ef144397bdd8f0daf579c5ee85
+PKG_HASH:=ee3179ee2b9a9107acec00eb546062cf7deb847f135a3b81503d22b0d226b3ed
PKG_MAINTAINER:=Oskari Rauta <oskari.rauta@gmail.com>
PKG_LICENSE:=Apache-2.0
diff --git a/utils/conmon/patches/010-remove-libdl-dep.patch b/utils/conmon/patches/010-remove-libdl-dep.patch
index 5a7640cdf..bcfb4d005 100644
--- a/utils/conmon/patches/010-remove-libdl-dep.patch
+++ b/utils/conmon/patches/010-remove-libdl-dep.patch
@@ -1,26 +1,11 @@
--- a/meson.build
+++ b/meson.build
-@@ -35,14 +35,6 @@ add_project_arguments('-Os', '-Wall', '-
-
- glib = dependency('glib-2.0')
-
--cc = meson.get_compiler('c')
--null_dep = dependency('', required : false)
--if cc.has_function('dlopen')
-- libdl = null_dep
--else
-- libdl = cc.find_library('dl')
--endif
--
- executable('conmon',
- ['src/conmon.c',
- 'src/config.h',
-@@ -78,7 +70,7 @@ executable('conmon',
+@@ -90,7 +90,7 @@ executable('conmon',
'src/utils.h',
'src/seccomp_notify.c',
'src/seccomp_notify.h'],
-- dependencies : [glib, libdl],
-+ dependencies : [glib],
+- dependencies : [glib, libdl, sd_journal, seccomp],
++ dependencies : [glib, sd_journal, seccomp],
install : true,
install_dir : join_paths(get_option('libexecdir'), 'podman'),
)