aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorHeinrich Schuchardt <xypron.glpk@gmx.de>2015-12-30 03:00:37 +0100
committerHeinrich Schuchardt <xypron.glpk@gmx.de>2015-12-30 03:21:56 +0100
commit0a61d56eb3ab55e2cc09dcf4d70252b42d0c978c (patch)
tree015662ebf5a6149b3df3aae4881943380991b793 /utils
parenta8ad5cd54d14fc705513f1a094562bf56e1e1007 (diff)
utils/gnupg: add new package gnupg-utils
The current package gnupg does not allow to receive keys due to disable-exec, disable-hkp configuration. The patch removes these switches. To avoid unduely increasing the package size the helper executables are put into a new package gnupg-utils. The version is bumped to 1.4.20 to avoid an error when receiving keys. Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de>
Diffstat (limited to 'utils')
1 files changed, 28 insertions, 5 deletions
diff --git a/utils/gnupg/Makefile b/utils/gnupg/Makefile
index c96fbc3a6..65209bb98 100644
--- a/utils/gnupg/Makefile
+++ b/utils/gnupg/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gnupg
-PKG_VERSION:=1.4.19
+PKG_VERSION:=1.4.20
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=ftp://ftp.franken.de/pub/crypt/mirror/ftp.gnupg.org/gcrypt/gnupg \
ftp://ftp.gnupg.org/gcrypt/gnupg
-PKG_MD5SUM:=3af4ab5b3113b3e28d3551ecf9600785
+PKG_MD5SUM:=b7af897a041c03c8ad1c7c466b54d10d
PKG_LICENSE:=GPL-3.0
PKG_LICENSE_FILES:=COPYING
@@ -24,7 +24,7 @@ PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
-define Package/gnupg
+define Package/gnupg/Default
SECTION:=utils
CATEGORY:=Utilities
DEPENDS:=+zlib +libncurses +libreadline
@@ -32,6 +32,17 @@ define Package/gnupg
URL:=http://www.gnupg.org/
endef
+define Package/gnupg
+ $(call Package/gnupg/Default)
+ MENU:=1
+endef
+
+define Package/gnupg-utils
+ $(call Package/gnupg/Default)
+ DEPENDS:=gnupg
+ TITLE:=Key management utilities for GnuPG
+endef
+
define Package/gnupg/description
GnuPG is GNU's tool for secure communication and data storage.
It can be used to encrypt data and to create digital signatures.
@@ -42,6 +53,11 @@ define Package/gnupg/description
with PGP2 because it uses IDEA (which is patented worldwide).
endef
+define Package/gnupg-utils/description
+ Key management utilies for GnuPG.
+ This package is needed to import keys from a keyserver.
+endef
+
CONFIGURE_ARGS += \
--disable-rpath \
--disable-asm \
@@ -49,9 +65,7 @@ CONFIGURE_ARGS += \
--disable-card-support \
--disable-agent-support \
--disable-bzip2 \
- --disable-exec \
--disable-ldap \
- --disable-hkp \
--disable-finger \
--disable-ftp \
--disable-dns-srv \
@@ -66,4 +80,13 @@ define Package/gnupg/install
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gpg $(1)/usr/bin/
endef
+define Package/gnupg-utils/install
+ $(INSTALL_DIR) $(1)/usr/lib/gnupg
+ for file in gpgkeys_curl gpgkeys_hkp; do \
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/gnupg/$$$$file \
+ $(1)/usr/lib/gnupg/; \
+ done
+endef
+
$(eval $(call BuildPackage,gnupg))
+$(eval $(call BuildPackage,gnupg-utils))