aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorMarko Ratkaj <marko.ratkaj@sartura.hr>2015-09-24 19:15:52 +0200
committerLuka Perkov <luka@openwrt.org>2015-09-27 23:44:26 +0200
commit00e774f37425d82843160c9edd0109d70bbe764e (patch)
treef83fc214c94bc646ba4a5b8889f0bc97445dfcd7 /utils
parent5b2245131b9ff8ed64e4c3ab5ab883d3d3a4b238 (diff)
lxc: bump version to 1.1.3
Signed-off-by: Marko Ratkaj <marko.ratkaj@sartura.hr>
Diffstat (limited to 'utils')
-rw-r--r--utils/lxc/Makefile6
-rw-r--r--utils/lxc/patches/016-uninitialized-ret-in-monitor.patch11
-rw-r--r--utils/lxc/patches/035-fix-undefined-lfd.patch12
3 files changed, 15 insertions, 14 deletions
diff --git a/utils/lxc/Makefile b/utils/lxc/Makefile
index 868e10066..de9cecf1d 100644
--- a/utils/lxc/Makefile
+++ b/utils/lxc/Makefile
@@ -8,15 +8,15 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=lxc
-PKG_VERSION:=1.1.2
-PKG_RELEASE:=2
+PKG_VERSION:=1.1.3
+PKG_RELEASE:=1
PKG_LICENSE:=LGPL-2.1+ BSD-2-Clause GPL-2.0
PKG_MAINTAINER:=Luka Perkov <luka@openwrt.org>
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://linuxcontainers.org/downloads/lxc/
-PKG_MD5SUM:=3ebadacf5fe8bfe689fd7a09812b682c
+PKG_MD5SUM:=197abb5a28ab0b689c737eb1951023fb
PKG_BUILD_DEPENDS:=lua
PKG_BUILD_PARALLEL:=1
diff --git a/utils/lxc/patches/016-uninitialized-ret-in-monitor.patch b/utils/lxc/patches/016-uninitialized-ret-in-monitor.patch
deleted file mode 100644
index 7eca2eaeb..000000000
--- a/utils/lxc/patches/016-uninitialized-ret-in-monitor.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/lxc/monitor.c
-+++ b/src/lxc/monitor.c
-@@ -181,7 +181,7 @@ int lxc_monitor_sock_name(const char *lx
- int lxc_monitor_open(const char *lxcpath)
- {
- struct sockaddr_un addr;
-- int fd,ret;
-+ int fd,ret = 0;
- int retry,backoff_ms[] = {10, 50, 100};
- size_t len;
-
diff --git a/utils/lxc/patches/035-fix-undefined-lfd.patch b/utils/lxc/patches/035-fix-undefined-lfd.patch
new file mode 100644
index 000000000..6b57e2690
--- /dev/null
+++ b/utils/lxc/patches/035-fix-undefined-lfd.patch
@@ -0,0 +1,12 @@
+--- a/src/lxc/bdev.c
++++ b/src/lxc/bdev.c
+@@ -1936,3 +1936,3 @@ static int loop_mount(struct bdev *bdev)
+ {
+- int lfd, ffd = -1, ret = -1;
++ int lfd = -1, ffd = -1, ret = -1;
+ struct loop_info64 lo;
+@@ -1974,3 +1974,3 @@ out:
+ if (ret < 0) {
+- close(lfd);
++ if (lfd > -1) close(lfd);
+ bdev->lofd = -1;