aboutsummaryrefslogtreecommitdiff
path: root/utils/zsh
diff options
context:
space:
mode:
authorOskari Rauta <oskari.rauta@gmail.com>2023-10-04 23:46:57 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-10-05 12:57:17 +0200
commita7f837c98b0ab3fde1b19283e13a21fdaf1b1ee2 (patch)
tree253fd62a29d1fe6d12c01bc0307d2c04b9d63cf3 /utils/zsh
parent5b3e517be4a1d2674fc12ea81a60ba885423758a (diff)
zsh: use autoreconf PKG_FIXUP to configure
In preparation to PCRE2 fixup, use autoreconf PKG_FIXUP as a better configure system instead of configure script. This is needed to reduce upcoming patch to migrate to PCRE2 library. To correctly use autoreconf it's needed to declare empty PKG_REMOVE_FILES. zsh include custom macro in the default aclocal.m4 When autoreconf PKG_FIXUP is used, if PKG_REMOVE_FILES is not defined, it's set to remove the file aclocal.m4 by default resulting in problem with the custom macro AC_PROG_LN. Signed-off-by: Oskari Rauta <oskari.rauta@gmail.com> [ split to 2 commit, add PKG_REMOVE_FILES, reword commit description ] Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'utils/zsh')
-rw-r--r--utils/zsh/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/utils/zsh/Makefile b/utils/zsh/Makefile
index 6fc713a5d..819dbe4ae 100644
--- a/utils/zsh/Makefile
+++ b/utils/zsh/Makefile
@@ -20,10 +20,19 @@ PKG_LICENSE:=ZSH
PKG_LICENSE_FILES:=LICENCE
PKG_CPE_ID:=cpe:/a:zsh_project:zsh
+PKG_FIXUP:=autoreconf
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
PKG_BUILD_FLAGS:=gc-sections lto
+# zsh include custom macro in the default aclocal.m4
+# When autoreconf PKG_FIXUP is used, if PKG_REMOVE_FILES
+# is not defined, it's set to remove the file aclocak.m4
+# by default resulting in problem with the custom macro
+# AC_PROG_LN
+# To prevent this, declare empty PKG_REMOVE_FILES
+PKG_REMOVE_FILES:=
+
include $(INCLUDE_DIR)/package.mk
define Package/zsh