aboutsummaryrefslogtreecommitdiff
path: root/utils/xfsprogs
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2023-05-17 20:29:40 +0800
committerNick Hainke <vincent@systemli.org>2023-05-17 15:37:59 +0200
commiteb8a3300d66edf520696c7c2fa47ca11d65f35df (patch)
treebb40ab157ee68407fbaeeba2b78887d80577b032 /utils/xfsprogs
parent5312113c5422693471652899d7ad0ee5d72c4e37 (diff)
xfsprogs: fix compilation with musl 1.2.4
musl 1.2.4 deprecated legacy "LFS64" ("large file support") interfaces so just having _GNU_SOURCE defined is not enough anymore. Manually pass -D_LARGEFILE64_SOURCE to allow to keep using LFS64 definitions. Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
Diffstat (limited to 'utils/xfsprogs')
-rw-r--r--utils/xfsprogs/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/utils/xfsprogs/Makefile b/utils/xfsprogs/Makefile
index 77cb58066..71cf38c7d 100644
--- a/utils/xfsprogs/Makefile
+++ b/utils/xfsprogs/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=xfsprogs
PKG_VERSION:=5.9.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/fs/xfs/xfsprogs
@@ -67,7 +67,7 @@ CONFIGURE_ARGS += \
--disable-scrub \
--disable-libicu
-TARGET_CFLAGS += -DHAVE_MAP_SYNC
+TARGET_CFLAGS += -DHAVE_MAP_SYNC $(if (CONFIG_USE_MUSL),-D_LARGEFILE64_SOURCE)
TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
define Package/xfs-admin/install