aboutsummaryrefslogtreecommitdiff
path: root/utils/wipe/Makefile
diff options
context:
space:
mode:
authorToni Uhlig <matzeton@googlemail.com>2019-09-14 09:13:26 +0200
committerToni Uhlig <matzeton@googlemail.com>2019-09-14 14:52:51 +0200
commit294fed056604808fe562d061ecd034a71a90cb67 (patch)
tree70408ca72f387b141931d8be3564bd41b38ba298 /utils/wipe/Makefile
parentd3b32a62c271d8be2f95b5962aa1015f24ddd849 (diff)
wipe: add new package
Signed-off-by: Toni Uhlig <matzeton@googlemail.com>
Diffstat (limited to 'utils/wipe/Makefile')
-rw-r--r--utils/wipe/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/utils/wipe/Makefile b/utils/wipe/Makefile
new file mode 100644
index 000000000..84053d314
--- /dev/null
+++ b/utils/wipe/Makefile
@@ -0,0 +1,42 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=wipe
+PKG_VERSION:=0.24
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/berke/$(PKG_NAME)/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=aefb4403333562f9af5e3e03ecbba4b124e98788c688662240f9b04d80bfdb2f
+
+PKG_MAINTAINER:=Toni Uhlig <matzeton@googlemail.com>
+PKG_LICENSE:=GPL-2.0-only
+
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/wipe
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=securely erase files
+ URL:=http://lambda-diode.com/software/wipe/
+endef
+
+define Package/wipe/description
+ wipe is a little command for securely erasing files from magnetic media.
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) linux \
+ CC_LINUX="$(TARGET_CC)" \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ LDFLAGS="$(TARGET_LDFLAGS)" \
+ CPPFLAGS="$(TARGET_CPPFLAGS)"
+endef
+
+define Package/wipe/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/wipe $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,wipe))