aboutsummaryrefslogtreecommitdiff
path: root/utils/vim/patches
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-02-25 19:47:00 -0800
committerRosen Penev <rosenp@gmail.com>2021-02-27 01:40:26 -0800
commitd5ddc98cb6070b1dd412c13ffab87e43722bb80d (patch)
tree7bd1fa8be95d066bc901bf6b732d28c9166b7636 /utils/vim/patches
parent7b04bc285e44ec2c577e206be06684d72fdfd65e (diff)
vim: fix compile with BUILD_NLS
Avoids having to use msgfmt, which happens to be broken with gettext-full. msgfmt is used for the desktop gvim application, which is not used here. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/vim/patches')
-rw-r--r--utils/vim/patches/010-no-msgfmt.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/utils/vim/patches/010-no-msgfmt.patch b/utils/vim/patches/010-no-msgfmt.patch
new file mode 100644
index 000000000..82e19bbc8
--- /dev/null
+++ b/utils/vim/patches/010-no-msgfmt.patch
@@ -0,0 +1,11 @@
+--- a/src/po/Makefile
++++ b/src/po/Makefile
+@@ -32,7 +32,7 @@ MSGMERGE = OLD_PO_FILE_INPUT=yes OLD_PO_
+ $(VIM) -u NONE -e -X -S check.vim -c "if error == 0 | q | endif" -c cq $<
+ touch $@
+
+-all: $(MOFILES) $(MOCONVERTED) $(MSGFMT_DESKTOP)
++all: $(MOFILES) $(MOCONVERTED)
+
+ check: $(CHECKFILES)
+